1+X云计算平台运维与开发认证(中级)样卷B——附答案

传送门
教育部职业教育将启动“1+X”证书制度改革
职业教育改革1+X证书制度试点启动
1+X成绩/证书查询入口

一、单选题(每题10分,共200分)

1.下面关于软件项目开发过程,叙述错误的是?(D)(10分)

A.敏捷开发从需求、计划、开发、测试,直到项目结束,整个周期一直在迭代中
B.敏捷开发中开发、测试、发布又可以单独迭代多次
C.瀑布式模型分为计划、分析、设计、程序开发、测试、修改和整合,一个阶段结束,另一个阶段接着开始
D.瀑布式模型着重迭代式开发,分析、设计、开发、测试和发布

2.敏捷开发从需求、计划、开发、测试,直到项目结束,整个周期一直在迭代中,而其中可以单独迭代多次的不包括哪个过程?(C)(10分)

A.开发
B.测试
C.计划
D.发布

3.以下关于STP协议的描述中,哪项是正确的?(C) (10分)

A.STP运行在交换机和网桥设备上
B.STP协议是一个二层链路管理协议
C.STP在选定根网桥,让一些端口进入阻塞工作模式,这些被阻塞端口没有被激活
D.STP的主要功能是在保证网络中没有回路的基础上,允许在第二层链路中提供冗余路径

4.以下哪个状态不是RSTP的工作状态?(A) (10分)

A.监听状态
B.丢弃状态
C.转发状态
D.学习状态

5.在常用的数据库表单管理命令当中,“use 数据库;”名称的作用是?(B)(10分)

A.描述表单
B.指定使用的数据库
C.显示当前已有的数据库
D.更新表单中的数据

6.在mysqldump备份命令当中,参数-u的作用是?(A)(10分)

A.数据库的用户名称
B.密码提示符
C.只导出表结构
D.备份完成后将不再允许修改数据

7.basic paxos流程中server的主要功能是什么?(A)(10分)

A.对投票结果进行统计
B.进行投票
C.筛选无用的投票
D.无任何功能

8.选完Leader以后,ZooKeeper就进入状态同步过程,具体方式如下:① Leader等待Server连接;② Follower连接Leader,将最大的zxid发送给Leader;③ Leader根据Follower的zxid确定同步点;④ 完成同步后通知Follower已经成为uptodate状态;⑤ Follower收到uptodate消息后,又可以重新接受client的请求进行服务了。请问正确的顺序是什么?(A)(10分)

A.12345
B.13245
C.12435
D.21345

9.Keystone为OpenStack平台提供了什么服务?(A)(10分)

A.认证服务
B.存储服务
C.镜像服务
D.计算服务

10.什么是私有云计算基础架构的基石?(A)(10分)

A.虚拟化
B.分布式
C.并行
D.集中式

11.Swift将Object存储在节点(Node)上,每个节点都是由多个硬盘组成的,并保证对象在多个节点上有备份,默认情况下,Swift会给所有数据保存多少个副本?(C)(10分)

A.1
B.2
C.3
D.4

12.以下关于行业云的描述中,错误的是哪项?(D)(10分)

A.能为行业的业务作专门的优化
B.能进一步方便用户
C.能进一步降低成本
D.可同时支持的范围较大,如金融云、政务云、医疗云、卫生云等

13.以下哪个不是小微企业使用云计算可以带来的好处?(D)(10分)

A.省下基础设施投资
B.省去底层人才投资
C.随时可用最新的资源
D.获得大量的机房管理经验

14.下列关于弹性伸缩服务中,描述正确的是?(C)(10分)

A.弹性伸缩服务中的服务器采用特殊软性材质生产
B.弹性伸缩的收费形式包括按需付费和包年包月两种
C.弹性伸缩是一种可以根据服务器压力的不同自动增加或减少实例的服务
D.以上皆为错误

15.以下关于不同租户间网络描述正确的是?(A)(10分)

A.在腾讯云中,不同租户之间可以设置冲突的IP地址
B.在腾讯云中,不同租户之间不可以设置冲突的IP地址
C.不同租户间网络默认可以互相通信
D.不同租户间无法通信

16.下面哪个是Docker用到的命名空间?(D)(10分)

A. PID命名空间
B. NET命名空间
C. IPC命名空间
D.以上都是

17.在Docker的描述文件Dockerfile中,RUN的含义是?(C)(10分)

A. 定义基础镜像
B. 作者或者维护者
C. 运行的Linux命令
D. 增加文件或目录

18.用户按照Shell语言规范编写程序并将其保存为?(A)(10分)

A.文件
B.目录
C.压缩包
D.图片

19.Ansible的参数中inventory文件的位置在哪个目录下_____。(C)(10分)

A./etc/ansible.cfg
B./etc/ansible
C./etc/ansible/hosts
D./var/log/ansible

20.Python模块,是一个Python文件,它的后缀是以_____结尾。(B)(10分)

A..yml
B..py
C..cpp
D..dll

二、多选题(每题10分,共200分)

21.下面对项目需求阶段表述正确的是?(ABCD)(10分)

A. 在软件需求阶段,要分析客户的业务活动,确定系统的目的、范围、定义和功能
B. 求的调研、挖掘和整理必须由项目经理牵头,由产品经理负责收集客户需求
C. 测试人员也需要参与需求分析、评审和总结
D. 需求也是项目的灵魂,有了需求才有项目开展的可能

22.关于变更阶段下面叙述错误的是?(AD)(10分)

A. 在整个软件开发过程中,需求变更会带来不确定性,但是是可以避免的
B. 按照变更的影响程度和客户投入,可以分为关键性需求、后续关键性需求、后续重要需求、改良型需求和可选性需求等。在时间优先级上进行管理和控制。
C. 对一个需求分析做得很好的项目来说,需求规格说明书定义的范围越详细越清晰,用户跟项目经理提出需求变更的几率就越小。
D. 合作双方在签订协议之初,书面约定不需要编写修改要求和执行过程。

23.WLAN中常用的加密方式有?(ABC) (10分)

A.wap
B.wep
C.wep2
D.tkip

24.交换网络中的冗余链路会产生?(ABC) (10分)

A.广播风暴
B.MAC地址表不稳定
C.多帧复制
D.交换机无法工作

25.下列有关Nginx配置文件nginx.conf的叙述正确的是?(AD)(10分)

A. nginx进程数设置为CPU总核心数最佳
B. 虚拟主机配置多个域名时,各域名间应用逗号隔开
C. sendfile on;表示为开启高效文件传输模式,对于执行下载操作等相关应用时,应设置为on
D. 设置工作模式与连接数上限时,应考虑单个进程最大连接数(最大连接数=连接数*进程数)

26.Linux系统上,下面哪些文件是与用户管理相关的配置文件?(ABC)(10分)

A. /etc/passwd
B./etc/shadow
C./etc/group
D./etc/password

27.下面哪些是Swift对象存储的特点?(ABC)(10分)

A.弹性可伸缩
B.高可用
C.分布式
D.集群式

28.下列选项当中,哪些不是Glance查看镜像列表的命令?(ACD)(10分)

A. glance iamges-show
B. glance image-list
C. glance images-list
D. glance image-show

29.下列选项当中,哪些说法是正确的?(BCD)(10分)

A. nova start是创建云主机
B. nova restart是重启云主机
C. nova boot是启动云主机
D. nova reset是重建云主机

30.AP注册失败的原因?(ABCD) (10分)

A. AP没有上电
B. AP连接的网线存在问题
C. AP设备提供的信息不匹配
D. 交换机设备不通

31.块存储服务(cinder)为实例提供块存储。存储的分配和消耗是由块存储驱动器,或者多后端配置的驱动器决定的。下面那些是可用的驱动程序。(ABD)(10分)

A.NAS/SAN
B.NFS
C.NTFS
D.Ceph

32.下列选项当中,哪些不是Glance查看镜像列表的命令(ACD)(10分)

A.glance images-show 
B.glance image-list
C.glance images-list
D.glance image-show 

33.关于openstack组件的描述以下正确的是?(ABD)(10分)

A. Heat是一个基于模板来编排复合云应用的服务。
B. Cinder的核心功能是对卷的管理,允许对卷、卷的类型、快照进行处理。
C. Neutron网络服务是OpenStack管理所有的网络方面的物理网络基础设施和访问层方面的虚拟网络基础设施
D. 网络也支持安全组。安全组允许管理员在组内定义防火墙规则。

34.腾讯云服务器分为上一代实例、当前一代实例、最新一代实例,若无特殊需求,一般建议新建实例时使用当前一代实例类型,下列哪些属于当前一代实例?(AB)(10分)

A. 高IO型I2
B. 计算型C2
C. 标准型 S1
D. 内存型 M3

35.下列关于专用宿主机与黑石物理服务器的描述正确的是?(ABC)(10分)

A. 专用宿主机是基于虚拟化技术的云服务器。黑石物理服务器属于裸金属架构
B. 黑石物理服务器提供的是可以按需购买、按量付费的物理服务器租赁服务
C. 专用宿主机是提供以独享宿主机资源的方式购买、创建云主机的服务
D. 专用宿主机无法和云服务器互相通信

36.相较于传统IDC,云计算具有哪些优势?(ABC)(10分)

A. 没有硬件购买和运维成本
B. 无需部署和配置实体硬件,资源交付时效性高
C. 资源可在短时间内按需弹性分配,减少资源闲置和浪费
D. 无需部署和维护用户自己开发的软件

37.以下哪些场景适合选择预付费(包年包月)的计费方式?(AC)(10分)

A. 具有较稳定的业务场景
B. 业务发展有较大波动性,且无法进行准确预测
C. 需要长期使用云资源,追求低成本
D. 资源使用有临时性和突发性

38.下面关于Docker容器的说法,正确的是?(ABC)(10分)

A.  容器是一个镜像的运行实例
B. 可以通过运行用户指定的指令进行启动、停止、删除
C. 通过命令分配一个伪终端可以进入容器操作
D. 容器都是相互可见的

39.常见的Python网页解析技术有_____。(ABCD)(10分)

A. 正则表达式
B. html.parser
C. lxml
D. Beautiful Soup

40.以下哪些是常见的Shell的种类_____。(ABCD)(10分)

A. Bourne Shell
B. Bourne-Again Shell
C. Korn Shell
D. Z Shell

三、实操题(共600分)

交换机管理(40分)

41.在eNSP中使用S5700交换机进行配置,通过一条命令划分vlan 2、vlan 3、vlan 1004,通过端口组的方式配置端口1-5为access模式,并添加至vlan2中。配置端口10为trunk模式,并放行vlan3。创建三层vlan 2,配置IP地址为:172.16.2.1/24,创建三层vlan1004,配置IP地址为:192.168.4.2/30。通过命令添加默认路由,下一跳为192.168.4.1。(使用完整命令)将上述操作命令及返回结果以文本形式提交到答题框。

[Huawei]vlan batch 2 3 1004
[Huawei]port-group 1
[Huawei-port-group-1]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/5
[Huawei-port-group-1]port link-type access
[Huawei-port-group-1]port default vlan 2
[Huawei]interface GigabitEthernet 0/0/10
[Huawei-GigabitEthernet0/0/10]port link-type trunk
[Huawei-GigabitEthernet0/0/10]port trunk allow-pass vlan 3
[Huawei]interface Vlanif 2
[Huawei-Vlanif2]ip address 172.16.2.1 24
[Huawei]interface Vlanif 1004
[Huawei-Vlanif1004]ip address 192.168.4.2 30
[Huawei]ip route-static 0.0.0.0 0 192.168.4.1

交换机管理(40分)

42.交换机配置:交换机g0/0/1端口连接R1路由器,所属vlan1001,配置地址192.168.1.2/30,与路由器通信。配置g0/0/2连接PC1机,所属vlan101,配置PC1机网关地址为172.16.101.254/24。配置默认路由下一跳为路由器地址。路由器配置:R1路由器g0/0/1端口配置地址12.12.12.1/30,配置端口多路复用PAT配置。R1路由器g0/0/2端口配置地址192.168.1.1/30,连接交换机。路由器配置默认路由访问外部网络,配置静态路由访问PC机网络。(所有配置命令使用完整命令)将上述操作命令及返回结果以文本形式提交到答题框。

[Huawei]vlan batch 101 1001
[Huawei]interface GigabitEthernet 0/0/1
[Huawei-GigabitEthernet0/0/1]port link-type access
[Huawei-GigabitEthernet0/0/1]port default vlan 1001
[Huawei-GigabitEthernet0/0/1]quit
[Huawei]interface vlan 1001
[Huawei-Vlanif1001]ip address 192.168.1.2 30
[Huawei]interface GigabitEthernet 0/0/2
[Huawei-GigabitEthernet0/0/2]port link-type access
[Huawei-GigabitEthernet0/0/2]port default vlan 101
[Huawei-GigabitEthernet0/0/2]quit
[Huawei]interface vlan 101
[Huawei-Vlanif101]ip address 172.16.101.254 24
[Huawei-Vlanif101]quit
[Huawei]ip route-static 0.0.0.0 0 192.168.1.1
[Huawei]acl number 2000
[Huawei-acl-basic-2000]rule 1 permit
[Huawei-acl-basic-2000]quit
[Huawei]interface GigabitEthernet 0/0/1
[Huawei-GigabitEthernet0/0/1]ip add
[Huawei-GigabitEthernet0/0/1]ip address 12.12.12.1 30
[Huawei-GigabitEthernet0/0/1]nat outbound 2000
[Huawei-GigabitEthernet0/0/1]quit
[Huawei]interface GigabitEthernet 0/0/2
[Huawei-GigabitEthernet0/0/2]ip address 192.168.1.1 30
[Huawei-GigabitEthernet0/0/2]quit
[Huawei]ip route-static 0.0.0.0 0 GigabitEthernet 0/0/1
[Huawei]ip route-static 172.16.101.0 255.255.255.0 192.168.1.2

YUM源管理(40分)

43.假设当前有一个centos7.2-1511.iso的镜像文件,使用这个文件配置yum源,要求将这个镜像文件挂载在/opt/centos目录。还存在一个ftp源,IP地址为192.168.100.200,ftp配置文件中配置为anon_root=/opt,/opt目录中存在一个iaas目录(该目录下存在一个repodata目录)请问如何配置自己的local.repo文件,使得可以使用这两个地方的软件包,安装软件。请将local.repo文件的内容以文本形式提交到答题框。

[centos]
name=centos
baseurl=file:///opt/centos
gpgcheck=0
enabled=1
[iaas]
name=iaas
baseurl=ftp://192.168.100.200/iaas
gpgcheck=0
enabled=1

Raid存储管理(40分)

44.登录云主机,在云主机中,存在一个大小为20G的硬盘为/dev/vdb,使用fdisk命令对该硬盘进形分区,要求分出两个大小为5G的分区。使用这两个分区,创建名为/dev/md0、raid级别为1的磁盘阵列。创建完成后使用xfs文件系统进形格式化,并挂载到/mnt目录下。将mdadm -D /dev/md0命令和df -h命令返回得结果以文本形式提交到答题框。

[root@xiandian ~]# mdadm -D /dev/md0
/dev/md0:
Version : 1.2
Creation Time : Wed Oct 23 17:08:07 2019
Raid Level : raid1
Array Size : 5238784 (5.00 GiB 5.36 GB)
Used Dev Size : 5238784 (5.00 GiB 5.36 GB)
Raid Devices : 2
Total Devices : 2
Persistence : Superblock is persistent
Update Time : Wed Oct 23 17:13:37 2019
State : clean
Active Devices : 2
Working Devices : 2
Failed Devices : 0
Spare Devices : 0
Name : xiandian:0 (local to host xiandian)
UUID : 71123d35:b354bc98:2e36589d:f0ed3491
Events : 17
Number Major Minor RaidDevice State
0 253 17 0 active sync /dev/vdb1
1 253 18 1 active sync /dev/vdb2
[root@xiandian ~]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/vda1 41G 2.4G 39G 6% /
devtmpfs 3.9G 0 3.9G 0% /dev
tmpfs 3.9G 4.0K 3.9G 1% /dev/shm
tmpfs 3.9G 17M 3.9G 1% /run
tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup
/dev/loop0 2.8G 33M 2.8G 2% /swift/node
tmpfs 799M 0 799M 0% /run/user/0
/dev/md0 5.0G 33M 5.0G 1% /mnt

主从数据库管理(40分)

45.使用提供的两台虚拟机,在虚拟机上安装mariadb数据库,并配置为主从数据库,实现两个数据库的主从同步。配置完毕后,请在从节点上的数据库中执行“show slave status \G”命令查询从节点复制状态,将查询到的结果以文本形式提交到答题框。

MariaDB [(none)]> start slave;
MariaDB [(none)]> show slave status\G
*************************** 1. row ***************************
Slave_IO_State: Waiting for master to send event
Master_Host: mysql1
Master_User: user
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: mysql-bin.000003
Read_Master_Log_Pos: 245
Relay_Log_File: mariadb-relay-bin.000005
Relay_Log_Pos: 529
Relay_Master_Log_File: mysql-bin.000003
Slave_IO_Running: Yes
Slave_SQL_Running: Yes
Replicate_Do_DB:
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 0
Last_Error:
Skip_Counter: 0
Exec_Master_Log_Pos: 245
Relay_Log_Space: 1256
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: No
Master_SSL_CA_File:
Master_SSL_CA_Path:
Master_SSL_Cert:
Master_SSL_Cipher:
Master_SSL_Key:
Seconds_Behind_Master: 0
Master_SSL_Verify_Server_Cert: No
<p>Last_IO_Errno: 0</p>
Last_IO_Error:
Last_SQL_Errno: 0
Last_SQL_Error:
Replicate_Ignore_Server_Ids:
Master_Server_Id: 30
1 row in set (0.00 sec)

读写分离数据库管理(40分)

46.使用提供的虚拟机与软件包,基于上一题构建的主从数据库,进一步完成Mycat读写分离数据库的配置安装。需要用的配置文件schema.xml文件如下所示(server.xml文件不再给出):select user()
配置读写分离数据库完毕后,使用netstat -ntpl命令查询端口启动情况。最后将netstat -ntpl命令的返回结果以文本形式提交到答题框。
在这里插入图片描述

Zookeeper集群(40分)

47.继续使用上题的三台虚拟机,使用提供的软件包,完成Zookeeper集群的安装与配置,配置完成后,在相应的目录使用./zkServer.sh status命令查看三个Zookeeper节点的状态,将三个节点的状态以文本形式提交到答题框。

[root@zookeeper1 bin]# ./zkServer.sh status
ZooKeeper JMX enabled by default
Using config: /root/zookeeper-3.4.14/bin/../conf/zoo.cfg
Mode: follower
[root@zookeeper2 bin]# ./zkServer.sh status
ZooKeeper JMX enabled by default
Using config: /root/zookeeper-3.4.14/bin/../conf/zoo.cfg
Mode: leader
[root@zookeeper3 bin]# ./zkServer.sh status
ZooKeeper JMX enabled by default
Using config: /root/zookeeper-3.4.14/bin/../conf/zoo.cfg
Mode: follower

Kafka集群(40分)

48.继续使用上题的三台虚拟机,使用提供软件包,完成Kafka集群的安装与配置,配置完成后,在相应的目录使用 ./kafka-topics.sh --create --zookeeper 你的IP:2181 --replication-factor 1 --partitions 1 --topic test创建topic,将输入命令后的返回结果以文本形式提交到答题框。

[root@zookeeper1 bin]# ./kafka-topics.sh --create --zookeeper 172.16.51.23:2181 --replication-factor 1 --partitions 1 --topic test
Created topic "test".

应用商城系统(40分)

49.继续使用上题的三台虚拟机,使用提供的软件包,基于集群应用系统部署。部署完成后,进行登录,(订单中填写的收货地址填写自己学校的地址,收货人填写自己的实际联系方式)最后使用curl命令去获取商城首页的返回信息,将curl http://你自己的商城IP/#/home获取到的结果以文本形式提交到答题框。

[root@server ~]# curl http://172.30.11.27/#/home
<!DOCTYPE html><html><head><meta charset=utf-8><title>1+x-示例项目</title><meta name=keywords content=""><meta name=description content=""><meta http-equiv=X-UA-Compatible content="IE=Edge"><meta name=wap-font-scale content=no><link rel="shortcut icon " type=images/x-icon href=/static/images/favicon.ico><link href=/static/css/app.8d4edd335a61c46bf5b6a63444cd855a.css rel=stylesheet></head><body><div id=app></div><script type=text/javascript src=/static/js/manifest.2d17a82764acff8145be.js></script><script type=text/javascript src=/static/js/vendor.4f07d3a235c8a7cd4efe.js></script><script type=text/javascript src=/static/js/app.81180cbb92541cdf912f.js></script></body></html><style>body{

Keystone管理(40分)

50.使用提供的“all-in-one”虚拟机,在keystone中创建用户testuser,密码为password,创建好之后,查看testuser的详细信息,以文本形式提交以上操作命令到答题框。

[root@xiandian~]# source /etc/keystone/admin-openrc.sh
[root@xiandian~]# openstack user create --domain xiandian --password password testuser
+-----------+----------------------------------+
| Field     | Value                           |
+-----------+----------------------------------+
| domain_id | 5a486c51bc8e4dffa4a181f6c54e0938 |
| enabled   | True                             |
| id       | ec6d67cdb3ac4b3ca827587c14be0a3e |
| name     | testuser                         |
+-----------+----------------------------------+
[root@xiandian~]# openstack user show testuser
+-----------+----------------------------------+
| Field | Value |
+-----------+----------------------------------+
| domain_id | 639e7d52170d4759b5438e3b29bbf339 |
| enabled | True |
| id | df8ca15f17a8435d8889987b4b78c7a2 |
| name | testuser |
+-----------+----------------------------------+

对象存储管理(40分)

51.使用提供的“all-in-one”虚拟机,使用openstack命令,创建名为examtest的容器并查询,上传一个aaa.txt(可自行创建)文件到这个容器中并查询。依次将操作命令和返回结果以文本形式提交到答题框。

[root@xiandian ~]# openstack container create examtest
+---------------------------------------+-----------+------------------------------------+
| account | container | x-trans-id |
+---------------------------------------+-----------+------------------------------------+
| AUTH_0ab2dbde4f754b699e22461426cd0774 | examtest | tx9e7b54f8042d4a6ca5ccf-005a93daf3 |
+---------------------------------------+-----------+------------------------------------+
[root@xiandian ~]# openstack container list
+----------+
| Name |
+----------+
| examtest |
+----------+
[root@xiandian ~]# openstack object create examtest aaa.txt
+---------+-----------+----------------------------------+
| object | container | etag |
+---------+-----------+----------------------------------+
| aaa.txt | examtest | 45226aa24b72ce0ccc4ff73eefe2e26f |
+---------+-----------+----------------------------------+
[root@xiandian ~]# openstack object list examtest
+---------+
| Name |
+---------+
| aaa.txt |
+---------+

Glance管理(40分)

52.登录“all-in-one”节点,使用crt的传输工具将提供的cirros-0.3.4-x86_64-disk.img镜像上传至“all-in-one”节点的/root目录下;使用glance命令将镜像上传,并命名为mycirros,最后使用glance命令查看该镜像的详细信息。将上述所有操作命令和返回结果以文本形式提交到答题框。

[root@xiandian ~]# source /etc/keystone/admin-openrc.sh
[root@xiandian ~]# glance image-create --name mycirros --disk-format qcow2 --container-format bare --progress < cirros-0.3.4-x86_64-disk.img
[=============================>] 100%
+------------------+--------------------------------------+
| Property | Value |
+------------------+--------------------------------------+
| checksum | ee1eca47dc88f4879d8a229cc70a07c6 |
| container_format | bare |
| created_at | 2019-10-24T10:16:52Z |
| disk_format | qcow2 |
| id | d3663be2-3ebf-443a-b3fc-b3e39bda8783 |
| min_disk | 0 |
| min_ram | 0 |
| name | mycirros |
| owner | 0ab2dbde4f754b699e22461426cd0774 |
| protected | False |
| size | 13287936 |
| status | active |
| tags | [] |
| updated_at | 2019-10-24T10:16:52Z |
| virtual_size | None |
| visibility | private |
+------------------+--------------------------------------+
[root@xiandian ~]# glance image-show d3663be2-3ebf-443a-b3fc-b3e39bda8783
+------------------+--------------------------------------+
| Property | Value |
+------------------+--------------------------------------+
| checksum | ee1eca47dc88f4879d8a229cc70a07c6 |
| container_format | bare |
| created_at | 2019-10-24T10:16:52Z |
| disk_format | qcow2 |
| id | d3663be2-3ebf-443a-b3fc-b3e39bda8783 |
| min_disk | 0 |
| min_ram | 0 |
| name | mycirros |
| owner | 0ab2dbde4f754b699e22461426cd0774 |
| protected | False |
| size | 13287936 |
| status | active |
| tags | [] |
| updated_at | 2019-10-24T10:16:52Z |
| virtual_size | None |
| visibility | private |
+------------------+--------------------------------------+

Docker安装(40分)

53.使用提供的虚拟机和软件包,自行配置YUM源,安装docker-ce服务。安装完毕后执行docker info命令的返回结果以文本形式提交到答题框。

Containers: 33
Running: 16
Paused: 0
Stopped: 17
Images: 22
Server Version: 18.09.6
Storage Driver: devicemapper
Pool Name: docker-253:0-113162281-pool
Pool Blocksize: 65.54kB
Base Device Size: 10.74GB
Backing Filesystem: xfs
Udev Sync Supported: true
Data file: /dev/loop0
Metadata file: /dev/loop1
Data loop file: /var/lib/docker/devicemapper/devicemapper/data
Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
Data Space Used: 3.573GB
Data Space Total: 107.4GB
Data Space Available: 18.72GB
Metadata Space Used: 22.59MB
Metadata Space Total: 2.147GB
Metadata Space Available: 2.125GB
Thin Pool Minimum Free Space: 10.74GB
Deferred Removal Enabled: true
Deferred Deletion Enabled: true
Deferred Deleted Device Count: 0
Library Version: 1.02.158-RHEL7 (2019-05-13)
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: b34a5c8af56e510852c35414db4c1f4fa6172339
runc version: 3e425f80a8c931f88e6d94a8c831b9d5aa481657
init version: fec3683
Security Options:
seccomp
Profile: default
Kernel Version: 3.10.0-1062.7.1.el7.x86_64
Operating System: CentOS Linux 7 (Core)
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.913GiB
Name: master
ID: U4ME:YWV6:WZEK:7R7W:5OLN:MO4A:NVNH:AEPR:L7GE:UD4S:UZOY:GZXQ
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
192.168.70.10:5000
127.0.0.0/8
Live Restore Enabled: false
Product License: Community Engine
WARNING: the devicemapper storage-driver is deprecated, and will be removed in a future release.
WARNING: devicemapper: usage of loopback devices is strongly discouraged for production use.
Use `--storage-opt dm.thinpooldev` to specify a custom block storage device.

Docker Harbor安装(40分)

54.使用提供的虚拟机与软件包,部署Docker Harbor镜像仓库服务。安装完毕后,将执行./install.sh --with-notary --with-clair命令返回结果中的[step4]的内容以文本形式提交到答题框。

[Step 4]: starting Harbor ...
✔ ----Harbor has been installed and started successfully.----
Now you should be able to visit the admin portal at https://10.24.2.37.
For more details, please visit https://github.com/vmware/harbor .

Shell脚本补全(40分)

55.下面有一段脚本,作用是自动配置nginx服务,由于工程师的失误,将脚本中的某些代码删除了,但注释还在,请根据注释,填写代码。最后将填写的代码按照顺序以文本形式提交至答题框。

nginx(){
cd
#删除默认项目路径下的文件
rm -rf /usr/share/nginx/html/*
#将提供的dist静态文件复制到nginx项目目录
cp -rvf /root/dist/* /usr/share/nginx/html
#修改nginx配置文件如下
cat > /etc/nginx/conf.d/default.conf << EOF
server {
listen 80;
server_name localhost;
#charset koi8-r;
#access_log /var/log/nginx/host.access.log main;
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
location /user {
(此处需要填写)
}
location /shopping {
proxy_pass http://127.0.0.1:8081;
}
location /cashier {
proxy_pass http://127.0.0.1:8083;
}
error_page 500 502 503 504 /50x.html;
location = /50x.html {
root /usr/share/nginx/html;
}
}
EOF
#启动nginx服务
systemctl start nginx
#设置nginx开机自启
(此处需填写)
#检查nginx服务是否成功启动
if [ $? -eq 0 ]
then
sleep 3
echo -e "\033[36m==========nginx启动成功==========\033[0m"
else
echo -e "\033[31m**********nginx启动失败,请检查**********\033[0m"
exit 1
fi
sleep 2
}

参考答案:

proxy_pass http://127.0.0.1:8082;
systemctl enable nginx

上一篇:1+X云计算平台运维与开发认证(中级)样卷A——附答案

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 像素格子 设计师: CSDN官方博客
应支付0元
点击重新获取
扫码支付

支付成功即可阅读