hihoCoder #1831 : 80 Days【思维 巧用队列】

描述

80 Days is an interesting game based on Jules Verne's science fiction "Around the World in Eighty Days". In this game, you have to manage the limited money and time.

Now we simplified the game as below:

There are n cities on a circle around the world which are numbered from 1 to n by their order on the circle. When you reach the city i at the first time, you will get ai dollars (ai can even be negative), and if you want to go to the next city on the circle, you should pay bi dollars. At the beginning you have c dollars.

The goal of this game is to choose a city as start point, then go along the circle and visit all the city once, and finally return to the start point. During the trip, the money you have must be no less than zero.

Here comes a question: to complete the trip, which city will you choose to be the start city?

If there are multiple answers, please output the one with the smallest number.

输入

The first line of the input is an integer T (T ≤ 100), the number of test cases.

For each test case, the first line contains two integers n and c (1 ≤ n ≤ 106, 0 ≤ c ≤ 109).  The second line contains n integers a1, …, an  (-109 ≤ ai ≤ 109), and the third line contains n integers b1, …, bn (0 ≤ bi ≤ 109).

It's guaranteed that the sum of n of all test cases is less than 106

输出

For each test case, output the start city you should choose.

提示

For test case 1, both city 2 and 3 could be chosen as start point, 2 has smaller number. But if you start at city 1, you can't go anywhere.

For test case 2, start from which city seems doesn't matter, you just don't have enough money to complete a trip.

样例输入

2
3 0
3 4 5
5 4 3
3 100
-3 -4 -5
30 40 50

样例输出

2
-1

【题意】

有n个城市围成一圈 编号为1-n

到达第i个城市需要花费ai金币 同时获得bi金币

起初有x金币

可以任意选择一个城市作为起点 

问能否从一个城市出发环游一圈?

【起点等于经过了两次】

 

【小结】

这是一道思维题 因为要求优先输出编号小的城市 我们可以从1开始依次枚举各个城市

如果可以到达这个城市就入队列  

如果当枚举到某一城市发现它不符合入队列的条件就说明从当前队列头的城市不能走到这个城市

于是让队头元素出队列 

如果发现仍不能入队列 就一直出队列

如果最终队列的元素为n

输出队头元素即可

【代码】

#include<bits/stdc++.h>
#define MAX 2000010
using namespace std;
typedef long long ll;

ll a[MAX],b[MAX];
queue<int>q;

int main()
{
    int t,n,i,j;
    ll x;
    scanf("%d",&t);
    while(t--){
        scanf("%d%lld",&n,&x);
        for(i=1;i<=n;i++){
            scanf("%lld",&a[i]);
        }
        for(i=n+1;i<=n+n;i++){
            a[i]=a[i-n];
        }
        for(i=1;i<=n;i++){
            scanf("%lld",&b[i]);
        }
        for(i=n+1;i<=n+n;i++){
            b[i]=b[i-n];
        }
        while(q.size()){
            q.pop();
        }
        int f=0;
        for(i=1;i<=n+n;i++){
            if(x+a[i]-b[i]>=0){
                x+=a[i]-b[i];
                q.push(i);
                if(q.size()>=n){
                    printf("%d\n",q.front());
                    f=1;
                    break;
                }
            }
            else{
                while(x+a[i]-b[i]<0&&q.size()){
                    x-=a[q.front()]-b[q.front()];
                    q.pop();
                }
                if(x+a[i]-b[i]>=0){
                    x+=a[i]-b[i];
                    q.push(i);
                    if(q.size()>=n){
                        printf("%d\n",q.front());
                        f=1;
                        break;
                    }
                }
            }
        }
        if(f==0) printf("-1\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值