GDUT_寒假训练题解报告_图论专题_个人题解报告——题目:L - Til the Cows Come Home

GDUT_寒假训练题解报告_图论专题_个人题解报告——题目:L - Til the Cows Come Home

题目:
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.
    Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    Hint
    INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.
裸的单源最短路,板子没的说,但是我被输入给坑死两次了,读题锅。
至于到底输入发生了什么不可描述的事情,看这段代码:

es[from-1][to-1]=min(value,es[from-1][to-1]);

对,他有可能两点之间有好几条路,你得把长的给去掉,我决定以后都要加这句话了,应该是这种图论题目的潜规则。
完整代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <climits>
#include <queue>
#include <stack>
#include <map>
//鬼畜头文件
using namespace std;
#define INF 0x3f3f3f3f
#define ULL unsigned long long
#define LL long long
//鬼畜define
//
int es[1010][1010];
int d[1010];
bool used[1010];
int main()
{
	int n,m;
	scanf("%d %d",&m,&n);
	fill(used,used+n,false);
	fill(d,d+n,INF);
	d[0]=0;
	memset(es,INF,sizeof(es));
	for(int time=0;time<m;time++)
	{
		int from,to,value;
		scanf("%d %d %d",&from,&to,&value);
		es[from-1][to-1]=min(value,es[from-1][to-1]);
		es[to-1][from-1]=es[from-1][to-1];
	}

	while(true)
	{
		int v=-1;
		for(int time=0;time<n;time++)
		{//取最短点
			if(!used[time]&&(v==-1||d[time]<d[v]))v=time;
		}
		if(v==-1)break;
		used[v]=true;
		for(int time=0;time<n;time++)
		{
			d[time]=min(d[time],d[v]+es[v][time]);
		}
	}
	printf("%d\n",d[n-1]);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值