HDU 1358 Period

题目链接:

[kuangbin带你飞]专题十六 KMP & 扩展KMP & ManacherE - Period

Description

For each prefix of a given string S with N characters (each character
has an ASCII code between 97 and 126, inclusive), we want to know
whether the prefix is a periodic string. That is, for each i (2 <= i
<= N) we want to know the largest K > 1 (if there is one) such that
the prefix of S with length i can be written as A K , that is A
concatenated K times, for some string A. Of course, we also want to
know the period K.

Input

The input file consists of several test cases. Each test case consists
of two lines. The first one contains N (2 <= N <= 1 000 000) � the
size of the string S. The second line contains the string S. The input
file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case
number on a single line; then, for each prefix with length i that has
a period K > 1, output the prefix size i and the period K separated by
a single space; the prefix sizes must be in increasing order. Print a
blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2 3 3
Test case #2
2 2
6 2
9 3
12 4

题目大意:

输入:

输入一个数字,表示字符串中有多少字母
输入一个字符串。 直至停止输入

输出:

Test case #%d
(1)在什么位置 (2)循环节出现的次数。每两组数据之间有一空行

第一次Presentation Error :输出格式错了,每组之间少了个空行

代码:

/*************************************************************************
    > File Name: hdu_1358_kmp循环节.cpp
    > Author: dulun
    > Mail: dulun@xiyoulinux.org
    > Created Time: 2016年03月14日 星期一 17时00分11秒
 ************************************************************************/

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;

const int N = 1e6+9;
int nxt[N];
char a[N];
int cnt = 0;

void getnxt()
{
    int k = 0;
    int len = strlen(a);
    for(int i = 1; i < len ; i++)
    {
        while(k && a[k] != a[i]) k = nxt[k-1];
        if(a[k] == a[i]) k++;
        nxt[i] = k;
    }
}


void sovle()
{
    getnxt();
    int n = strlen(a);
    printf("Test case #%d\n", ++cnt);
    for(int i = 1; i < n; i++)
    {
        int t = (i+1) - nxt[i];//循环节长度
        if( nxt[i] == 0 ) continue;
        if((i+1) % t == 0) //刚好循环 (i+1)/t 个周期
        {
            printf("%d %d\n", i+1, (i+1) / t );
        }
    }
    printf("\n");.//注意每组数据之间要有换行
}

int main()
{
    int n;
    while(~scanf("%d", &n) && n)
    {
        int n;
        scanf("%d", &n);
        scanf("%s", a);
        sovle();
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值