HDU__1003Max Sum(最大连续子序列和)

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.





Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).





Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.





Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5





Sample Output

Case 1:
14 1 4

Case 2:

7 1 6

算是比较明显的DP题,很容易推出状态转移方程:sum[i] = max{sum[i-1]+a[i],a[i]}.

但是DP的代码也有好坏之分,我一开始就想麻烦了,觉得还得存起始下标和终点下标是不是得用个结构体啊,结果打完才发现,用不用结构体,dp的时候都得优化sum,左右下标,所以嘿嘿,第二遍才感觉正式的做出来了

比较好的(二改后)

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int putcnt = 0;
int main()
{
	int t,n,a,b,sum,retmax,l,r,L,R;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(int i = 1;i <= n;i++)
		{
			cin>>a; 
			if(i == 1)
			{
				sum = a;
				retmax = a;
				l = L = i;
				r = R = i;
			}
			else
			{
				if(b + a >= a)
				{
					sum += a;
					r = i;
				} 
				else
				{
					sum = a;
					l = i;
					r = i;
				}
				if(sum > retmax)
				{
					retmax = sum;
					L = l;
					R = r;
				}
			}	
			b = sum;
			//cout<<b<<endl;
		}
		printf("Case %d:\n",++putcnt);
		cout<<retmax<<" "<<L<<" "<<R<<endl;
		
		
		
		if(t >= 1)
		{
			cout<<"\n";
		}
	}
	
	
	
	return 0;
 } 


一开始(麻烦的代码)
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
	int l;
	int r;
	int retmax;
}findmax[100005];
int putcnt = 0;
int main()
{
	int t,n,a,b,ret,retflag,l,r;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(int i = 1;i <= n;i++)
		{
			cin>>a; 
			if(i == 1)
			{
				findmax[i].l = 1;
				findmax[i].r = 1;
				findmax[i].retmax = a;
				ret = i;
				retflag = a;
			}
			else
			{
				if(b + a >= a)
				{
					findmax[i].retmax = b + a;
					findmax[i].l = findmax[i - 1].l;
					findmax[i].r = i;
					
				} 
				else
				{
					findmax[i].retmax = a;
					findmax[i].l = i;
					findmax[i].r = i;
				}
				if(findmax[i].retmax > retflag)
				{
					retflag = findmax[i].retmax;
					ret = i;
				}
			}	
			b = findmax[i].retmax;
			//cout<<b<<endl;
		}
		printf("Case %d:\n",++putcnt);
		cout<<findmax[ret].retmax<<" "<<findmax[ret].l<<" "<<findmax[ret].r<<endl;
		
		
		
		if(t >= 1)
		{
			cout<<"\n";
		}
	}
	
	
	
	return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值