乳草的入侵

题目链接:http://liuseroj.cc/problem/3312

样例
样例输入
复制4 3 1 1
....
..*.
.**.
样例输出
复制4

代码:

#include<bits/stdc++.h>
using namespace std;
typedef pair<int,int> PII;
const int N=510;
int n,m,ex,ey;
char a[N][N];
int d[N][N];

const int dx[8]={0,0,1,1,1,-1,-1,-1};
const int dy[8]={1,-1,1,0,-1,1,0,-1};

int bfs() {
    queue<PII> q;
    q.push({ex,ey});
    d[ex][ey]=0;
    int res=-0x3f3f3f3f;
    while(!q.empty())
    {
        auto t=q.front(); q.pop();
        for(int i=0;i<8;i++)
        {
            int x=dx[i]+t.first,y=dy[i]+t.second;
            if(x<=0||x>m||y<=0||y>n||a[x][y]=='*'||d[x][y]!=-1) continue;
            d[x][y]=d[t.first][t.second]+1;
            res=max(res,d[x][y]);
            q.push({x,y});
        }
    }
    return res;
}

int main() {
    memset(d,-1,sizeof d);
    int x,y;
    cin>>n>>m>>x>>y;
    ex=m-y+1,ey=x;  
    for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
            cin>>a[i][j];
    cout<<bfs()<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值