Python安装pyecharts所遇问题及解决办法

       最近学习到数据可视化内容,老师推荐安装pyecharts,于是pip install 了一下,结果...掉坑了,下面是我的跳坑经验,如果你有类似问题,希望对你有所帮助。

       第一个坑:

   

     这个不难理解,缺少pyecharts-jupyter-installer嘛,那就安一个呗。可能有人注意到,我使用的是python2 -m pip ...(这种写法是为了解决python 2和3共存时pip的冲突问题,具体解释在本页最后。)

     本以为结束了,却掉进了第二个坑:


    看到这个,很明显是安装MarkupSafe时出错了,但后面的 F:python 2.7.8....-u -c"import setuptools.....,我不得不说一句-'请原谅我水平低'...而去网上搜了半天,没几篇符合的,有一篇倒是解决了,却是linux环境,看来只能自己'摸黑过河了'...

    先按照套路单独 pip install 了一下,但还是报了相同的错:

       然后又按照它给的提示加 -u - c两个参数,又去分析出错文件位置, 然而,并没有什么**...

       仔细想了想,应该是MarkupSafe不支持pip直接安装的问题,那换个安装方式呗,比如安装它的.whl文件,可以点python第三方库.whl文件下载,然后下载安装。.whl文件安装方法下图。


'幸福'来得如此突然....这下pyecharts还不'束手就擒'?偷笑



最后放个小测试。(程序运行后,会在其所在目录生成render.html文件,浏览器打开就可以看效果了)



   写在最后: python2和3共存时pip冲突问题的解决办法

       1.将2和3目录下的python.exe和pythonw.exe分别加上对应版本号,如2下的改为python2.exe, pythonw2.exe

       2.pip安装时,如要安装在2目录下,可这样写:python2 -m pip install 库名

阅读更多
相关热词: python安装
上一篇Python操作mysql数据库
下一篇ImportError:DLL load failed,找不到指定模块的解决办法
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭