HDU 4009 Transfer water 最小树形图(简单题)


Transfer water

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 3096    Accepted Submission(s): 1154


Problem Description
XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water line from other household. If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water is not lower than the one which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except the water line. Z dollar should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b, c) of every household the c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.
 

Input
Multiple cases.
First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000).
Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000.
Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th household.
If n=X=Y=Z=0, the input ends, and no output for that.
 

Output
One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line.
 

Sample Input
   
   
2 10 20 30 1 3 2 2 4 1 1 2 2 1 2 0 0 0 0
 

Sample Output
   
   
30
Hint
In 3‐dimensional space Manhattan distance of point A (x1, y1, z1) and B(x2, y2, z2) is |x2‐x1|+|y2‐y1|+|z2‐z1|.
 

Source
 

Recommend
lcy


题意是说在一个高山上有很多房子需要建一个井和水流通道,每个房子都可以建井,井的费用是此房子高度*X,某些房子之间可以建水流通道,如果水流从房子a流向房子b,而且a的高度高于b,那么费用就只需他们之间的距离*Y,否则还要加上买水泵的钱Z。让你求最少花费使得所有房子都能供上水。
最小树形图入门题,建图:
将能够连接的房子之间建立通道,费用为两房子之间建立通道的费用。
设水井为一个超级源,然后这个超级源连接每个房子,费用为每个房子建立水井的花费。
最后直接套用朱刘算法模板即可。

#include<stdio.h>
#include<string.h>
#include<math.h>
#define M 1007
#define inf 0x3f3f3f
using namespace std;
int pre[M],vis[M],id[M];
int in[M];
int n,x,y,z;

struct Node
{
    int u,v;
    int cost;
}E[M*M+5];

struct point
{
    int x,y,z;
}p[M];

int dis(point a,point b)
{
    int ans=(fabs(a.x-b.x)+fabs(a.y-b.y)+fabs(a.z-b.z))*y;
    if(a.z<b.z)
        ans+=z;
    return ans;
}

int direct_mst(int root,int nv,int ne)
{
    int ret=0;
    while(true)
    {
        //找最小入边
        for(int i=0;i<nv;i++)
            in[i]=inf;
        for(int i=0;i<ne;i++)
        {
            int u=E[i].u;
            int v=E[i].v;
            if(E[i].cost<in[v]&&u!=v)
            {
                pre[v]=u;
                in[v]=E[i].cost;
            }
        }
        for(int i=0;i<nv;i++)
        {
            if(i==root)continue;
            if(in[i]==inf)return -1;
        }
        //找环
        int cntnode=0;
        memset(id,-1,sizeof(id));
        memset(vis,-1,sizeof(vis));
        in[root]=0;
        for(int i=0;i<nv;i++)//标记每个环
        {
            ret+=in[i];
            int v=i;
            while(vis[v]!=i&&id[v]==-1&&v!=root)
            {
                vis[v]=i;
                v=pre[v];
            }
            if(v!=root&&id[v]==-1)
            {
                for(int u=pre[v];u!=v;u=pre[u])
                {
                    id[u]=cntnode;
                }
                id[v]=cntnode++;
            }
        }
        if(cntnode==0)break;//无环
        for(int i=0;i<nv;i++)
            if(id[i]==-1)
                id[i]=cntnode++;
        //缩点,重新标记
        for(int i=0;i<ne;i++)
        {
            int v=E[i].v;
            E[i].u=id[E[i].u];
            E[i].v=id[E[i].v];
            if(E[i].u!=E[i].v)
            {
                E[i].cost-=in[v];
            }
        }
        nv=cntnode;
        root=id[root];
    }
    return ret;
}

int main()
{
    while(scanf("%d%d%d%d",&n,&x,&y,&z),n|x|y|z)
    {
        int num=0,flag,to;
        for(int i=1;i<=n;i++)
            scanf("%d%d%d",&p[i].x,&p[i].y,&p[i].z);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&flag);
            while(flag--)
            {
                scanf("%d",&to);
                E[num].u=i;
                E[num].v=to;
                if(to!=i)
                    E[num].cost=dis(p[E[num].u],p[E[num].v]);
                else
                    E[num].cost=inf;
                num++;
            }
        }
        for(int i=1;i<=n;i++)
        {
            E[num].u=0;
            E[num].v=i;
            E[num].cost=p[i].z*x;
            num++;
        }
        int ans=direct_mst(0,n+1,num);
        if(ans==-1)
            printf("poor XiaoA\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【优质项目推荐】 1、项目代码均经过严格本地测试,运行OK,确保功能稳定后才上传平台。可放心下载并立即投入使用,若遇到任何使用问,随时欢迎私信反馈与沟通,博主会第一时间回复。 2、项目适用于计算机相关专业(如计科、信息安全、数据科学、人工智能、通信、物联网、自动化、电子信息等)的在校学生、专业教师,或企业员工,小白入门等都适用。 3、该项目不仅具有很高的学习借鉴价值,对于初学者来说,也是入门进阶的绝佳选择;当然也可以直接用于 毕设、课设、期末大作业或项目初期立项演示等。 3、开放创新:如果您有一定基础,且热爱探索钻研,可以在此代码基础上二次开发,进行修改、扩展,创造出属于自己的独特应用。 欢迎下载使用优质资源!欢迎借鉴使用,并欢迎学习交流,共同探索编程的无穷魅力! 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值