HDU 1028 Ignatius and the Princess III 整数的拆分


Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11071    Accepted Submission(s): 7834


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
   
   
4 10 20
 

Sample Output
   
   
5 42 627
 

Author
Ignatius.L


求整数的拆分数,也就是求不同的等式个数。整数拆分也是一种普通母函数题目的类型。
//15MS	236K
#include<stdio.h>
#include<string.h>
#define M 127
int c1[M],c2[M];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<=n;i++)c1[i]=1;//c1保存当前得到的多项式各项系数
        memset(c2,0,sizeof(c2));//c2保存每次计算时临时的结果
        for(int i=2; i<=n; i++) //要乘以n个多项式
        {
            for(int j=0; j<=n; j++) //c1的各项指数
                for(int k=0;j+k<=n;k+=i)
                    c2[j+k]+=c1[j];//指数相加得j+k,加多少只取决于c1[j]的系数,因为被乘多项式的各项系数均为1
            memcpy(c1,c2,sizeof(c2));
            memset(c2,0,sizeof(c2));
        }
        printf("%d\n",c1[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值