LA 4670 Dominating Patterns AC自动机简单题

4670 - Dominating Patterns

Time limit: 3.000 seconds

The archaeologists are going to decipher a very mysterious ``language". Now, they know many language patterns; each pattern can be treated as a string on English letters (only lower case). As a sub string, these patterns may appear more than one times in a large text string (also only lower case English letters).

What matters most is that which patterns are the dominating patterns. Dominating pattern is the pattern whose appearing times is not less than other patterns.

It is your job to find the dominating pattern(s) and their appearing times.

Input 

The entire input contains multi cases. The first line of each case is an integer, which is the number of patterns N1$ \le$N$ \le$150. Each of the following N lines contains one pattern, whose length is in range [1, 70]. The rest of the case is one line contains a large string as the text to lookup, whose length is up to 106.

At the end of the input file, number `0' indicates the end of input file.

Output 

For each of the input cases, output the appearing times of the dominating pattern(s). If there are more than one dominating pattern, output them in separate lines; and keep their input order to the output.

Sample Input 

2 
aba 
bab 
ababababac 
6 
beta 
alpha 
haha 
delta 
dede 
tata 
dedeltalphahahahototatalpha 
0

Sample Output 

4 
aba 
2 
alpha 
haha

给你n个单词,然后一个文本串,让你求在这个文本串当中出现次数最多的单词,并打印出来。不一定只有一个单词,可能有多个单词出现的数量一样多。
Trie的每个节点用vector记录该节点结尾的单词的标号,数组ans记录每个单词出现的次数。只需在模板上将query部分最后的查询稍加修改即可。
//0.156
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
char str[1000007],s[1007][107];
int ans[1007];
int head,tail;
struct node
{
    node *next[26];//Trie每个节点的26个字节点
    node *fail;//失效指针
    int count;//是否为该单词的最后一个节点
    vector<int>id;
    node()//构造函数初始化
    {
        count=0;
        id.clear();
        fail=NULL;
        memset(next,0,sizeof(next));
    }
} *q[500001];//队列,方便用于bfs构造失效指针
void insert(node *root,char str[],int id)
{
    node *p=root;
    int i=0,index;
    while(str[i])
    {
        index=str[i]-'a';
        if(p->next[index]==NULL)p->next[index]=new node();
        p=p->next[index];
        i++;
    }
    p->count++;//在单词的最后一个节点count+1,代表一个单词
    p->id.push_back(id);
}
void build_ac(node *root)
{
    root->fail=NULL;
    q[head++]=root;
    while(head!=tail)
    {
        node *temp=q[tail++];
        node *p=NULL;
        for(int i=0;i<26;i++)
        {
            if(temp->next[i]!=NULL)
            {
                if(temp==root)temp->next[i]->fail=root;
                else
                {
                    p=temp->fail;
                    while(p!=NULL)
                    {
                        if(p->next[i]!=NULL)
                        {
                            temp->next[i]->fail=p->next[i];
                            break;
                        }
                        p=p->fail;
                    }
                    if(p==NULL)temp->next[i]->fail=root;
                }
                q[head++]=temp->next[i];
            }
        }
    }
}
int query(node *root)
{
    int i=0,cnt=0,index;
    node *p=root;
    while(str[i])
    {
        index=str[i]-'a';
        while(p->next[index]==NULL&&p!=root)p=p->fail;
        p=p->next[index];
        p=(p==NULL)?root:p;
        node *temp=p;
        while(temp!=root&&temp->count>=0)//修改的部分
        {
            for(int j=0;j<(temp->id.size());j++)
                ans[temp->id[j]]++;
            temp=temp->fail;
        }
        i++;
    }
    return cnt;
}
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        head=tail=0;
        node *root=new node();
        memset(ans,0,sizeof(ans));
        for(int i=0;i<n;i++)
        {
            scanf("%s",s[i]);
            insert(root,s[i],i+1);
        }
        build_ac(root);
        scanf("%s",str);
        query(root);
        int maxx=0;
        for(int i=1;i<=n;i++)
            if(ans[i]>maxx)maxx=ans[i];
        printf("%d\n",maxx);
        for(int i=1;i<=n;i++)
            if(ans[i]==maxx)
                printf("%s\n",s[i-1]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值