HDU 4952 Number Transformation 打表规律


Number Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 495    Accepted Submission(s): 248


Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

Sample Input
   
   
2520 10 2520 20 0 0
 

Sample Output
   
   
Case #1: 2520 Case #2: 2600
 

Source
 

给你一个数x和k次操作,要求没次操作使得x*n能整除i,并且x*n是最接近x的数,求最后的数。
(i+1)*x'>=i*x  =>  x'>=i*x/(i+1)  =>  x'>=x-x/(i+1)  当x  <=i+1的时候,x'就不变了,所以暴力求解就可以了。
//93MS	256K
#include<stdio.h>
#include<string.h>
#define ll __int64
ll a,b;

int main()
{
    int cas=1;
    while(scanf("%I64d%I64d",&a,&b),a|b)
    {
        ll i,c;
        int flag=0;
        for(i=1;i<=b;i++)
        {
            if(a%i)
            {
                c=a/i+1;a=c*i;
                //printf("a=%I64d,c=%I64d,i=%I64d\n",a,c,i);
                if(c<=i){flag=1;break;}
            }
        }
        if(flag)printf("Case #%d: %I64d\n",cas++,c*b);
        else printf("Case #%d: %I64d\n",cas++,a);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值