POJ 3071 Football 概率dp


Football
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3309 Accepted: 1696

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source



有2^n支球队,已知每支球队赢得其他球队的概率,相邻的两两比赛,求最后哪只球队获得冠军的概率最高。

设dp[i][left][right]表示i这支球队在第left到第right球队里面得到冠军的概率,所以最后需要的是dp[i][1][16]。一个球队要在当前的阶段得到冠军必须在之前得到冠军

所以mid=(left+right)/2;  

i和j在[left,right]里面争夺冠军(例如i和j在1到16里面争夺冠军,也就是争夺总冠军),那么i和j必定是来自于两个分区,left<=i<=mid和mid+1<=j<=right

即状态转移方程:dp[j][l][r]+=beat[j][k]*dp[j][l][mid]*dp[k][mid+1][r];
           dp[k][l][r]+=beat[k][j]*dp[j][l][mid]*dp[k][mid+1][r];

//17356K	454MS
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
double beat[129][129],dp[129][129][129];
int main()
{
    int n;
    while(scanf("%d",&n)&&n!=-1)
    {
        n=(int)pow(2,n);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%lf",&beat[i][j]);
        int r,mid;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)dp[i][i][i]=1;
        for(int i=2;i<=n;i<<=1)//第几次淘汰赛
            for(int l=1;l<=n;l+=i)//每次淘汰赛的左区间
            {
                r=l+i-1;//每次淘汰赛的右区间
                mid=(l+r)>>1;
                for(int j=l;j<=mid;j++)
                    for(int k=mid+1;k<=r;k++)
                    {
                        dp[j][l][r]+=beat[j][k]*dp[j][l][mid]*dp[k][mid+1][r];
                        dp[k][l][r]+=beat[k][j]*dp[j][l][mid]*dp[k][mid+1][r];
                    }
            }
        double maxx=-1;
        int pos;
        for(int i=1;i<=n;i++)
        {
            if(dp[i][1][n]>maxx)
            {
                maxx=dp[i][1][n];
                pos=i;
            }
        }
        printf("%d\n",pos);
    }
    return 0;
}


从网上发现还可以用位运算来解决此题,效率要提高很多。
//528K	79MS
#include<stdio.h>
#include<string.h>
double p[129][129],dp[17][129];
int main()
{
    int n;
    while(scanf("%d",&n)&&n!=-1)
    {
        for(int i=0;i<(1<<n);i++)
            for(int j=0;j<(1<<n);j++)
                scanf("%lf",&p[i][j]);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<(1<<n);i++)dp[0][i]=1;
        for(int i=1;i<=n;i++)
            for(int j=0;j<(1<<n);j++)
                for(int k=0;k<(1<<n);k++)
                    if(((j>>(i-1))^1)==(k>>(i-1)))
                        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
        double maxx=-1;
        int pos;
        for(int i=0;i<(1<<n);i++)
        {
            if(dp[n][i]>maxx)
            {
                maxx=dp[n][i];
                pos=i+1;
            }
        }
         printf("%d\n",pos);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值