HDU2051 Bitset


点击打开链接

 

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9132    Accepted Submission(s): 7037


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 


 

Input
For each case there is a postive number n on base ten, end of file.
 


 

Output
For each case output a number on base two.
 


 

Sample Input
  
  
1 2 3
 


 

Sample Output
  
  
1 10 11
 


 

Author
8600 && xhd
 


 

Source
 


 

Recommend
linle
 
 
这道题用栈比较好做。
 
 
#include<stdio.h>
#include<iostream>
#include<stack>
using namespace std;
int main()
{
    int m;
    stack<int> z;
    while(scanf("%d",&m)!=EOF)
    {
       int x=m;
       while(x>0)
       {
           z.push(x%2);
           x/=2;
       }
       while(!z.empty())
       {
           cout<<z.top();
           z.pop();
       }
       printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值