Second-price Auction




Second-price Auction
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Do you know second-price auction? It's very simple but famous. In a second-price auction, each potential buyer privately submits, perhaps in a sealed envelope or over a secure connection, his (or her) bid for the object to the auctioneer. After receiving all the bids, the auctioneer then awards the object to the bidder with the highest bid, and charges him (or her) the amount of the second-highest bid.

Suppose you're the auctioneer and you have received all the bids, you should decide the winner and the amount of money he (or she) should pay.

Input

There are multiple test cases. The first line of input contains an integer T(T <= 100), indicating the number of test cases. Then T test cases follow.

Each test case contains two lines: The first line of each test case contains only one integerN, indicating the number of bidders. (2 <= N <= 100) The second line of each test case containsN integers separated by a space. The i-th integer Pi indicates thei-th bidder's bid. (0 < Pi <= 60000) You may assume that the highest bid is unique.

Output

For each test case, output a line containing two integers x and y separated by a space. It indicates that thex-th bidder is the winner and the amount of money he (or she) should pay isy.

Sample Input

2
3
3 2 1
2
4 9

Sample Output

1 2
2 4






#include<stdio.h>
#include<algorithm>
using namespace std;
int z[1007];
int cmp(int a1,int b1)
{
    return a1>b1;
}
int main()
{
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        while(m--)
        {
            int n;
            scanf("%d",&n);
            for(int a=0;a<n;a++)
            scanf("%d",&z[a]);
            int max=z[0],flag=0;
            for(int  b=0;b<n;b++)
            if(z[b]>max){max=z[b],flag=b;}
            sort(z,z+n,cmp);
            printf("%d %d\n",flag+1,z[1]);


        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值