HDU 1385 Minimum Transport Cost 最短路+字典序


Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5380    Accepted Submission(s): 1353


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
   
   
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
   
   
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source
 

Recommend
Eddy
 

题意:有N条路,有的路之间可以连接,并且有一定的费用。而且经过某条路的时候需要增加相关的费用(不包括起点和终点)。求两条路之间最少的费用。并按照字典序输出路径。
思路:求最短路+字典序输出。字典序输出比较麻烦。记录路径思路就是加入一个pre[ ]数组 时时更新每个点前面的点是什么 , 另外不要忘记从始点出发到i的所有的pre都要赋值初始点。
#include<stdio.h>
#include<string.h>
#define size 1000
int val[size],map[size][size],used[size],min[size],n,start[size],end[size],flag,pre[size];
char s1[1300],s2[1300];
int ok(int n1,int n2,int s)//比较字典序大小
{
	int i,k;
    i=0;
    s1[i++]=n1+'0';
    k=pre[n1];
    while(k!=s)
    {
		s1[i++]=k+'0';
		k=pre[k];
    }
    s1[i++]=s+'0';
    s1[i]='\0';
    strrev(s1);//把字符串翻转过来
    i=0;
    s2[i++]=n1+'0';
    k=n2;//因为依然是n1(j)为最后一个 通过n2(pos)架桥
    while(k!=s)
    {
		s2[i++]=k+'0';
		k=pre[k];
    }
    s2[i++]=s+'0';
    s2[i]='\0';
    strrev(s2);
    if(strcmp(s2,s1)<0)
		return 1;
    else  return 0;
}
void find_short(int s)
{
	int i,j,mm,pos;
	memset(used,0,sizeof(used));
	for(i=1;i<=n;i++)
	{
		min[i]=map[s][i];
		if(map[s][i]!=999999999) //这一步居然忘记了 阿弥陀佛  记住这个千万不能少
			pre[i]=s;
	}
	min[s]=0;used[s]=1;
	for(i=2;i<=n;i++)
	{
		mm=999999999;
		for(j=1;j<=n;j++)
		{
			if(!used[j]&&mm>min[j])
			{
				pos=j;
				mm=min[j];
			}
		}
		if(mm==999999999) break;
		used[pos]=1;
		for(j=1;j<=n;j++)
			if(!used[j]&&min[pos]+map[pos][j]+val[pos]<min[j])
			{
				min[j]=min[pos]+map[pos][j]+val[pos];
				pre[j]=pos;
			}
			else
				if(!used[j]&&min[pos]+map[pos][j]+val[pos]==min[j])
					if(ok(j,pos,s)) pre[j]=pos;//如果pos之前的字典序较小那么更新
	}
}
void print(int s,int e)
{
	int a[size],i,k;
	k=0;
	a[k++]=e;
	i=e;
	while(s!=i)
	{
		i=pre[i];
		a[k++]=i;
	}
	printf("Path: ");
	for(i=k-1;i>0;i--)
		printf("%d-->",a[i]);
	printf("%d\n",a[0]);
}
int main()
{
	int i,j,s,e,num;
	while(scanf("%d",&n)&&n!=0)
	{
		num=0;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j]==-1) map[i][j]=999999999;
			}
			for(i=1;i<=n;i++)
				scanf("%d",&val[i]);
			while(1)
			{
				scanf("%d %d",&s,&e);
				if(s==-1&&e==-1) break;
				start[num]=s;
				end[num++]=e;
			}
			for(i=0;i<num;i++)
			{
				//flag=0;
				find_short(start[i]);
				printf("From %d to %d :\n",start[i],end[i]);
				if(start[i]!=end[i])
					print(start[i],end[i]);
				else printf("Path: %d\n",start[i]);
				printf("Total cost : %d\n",min[end[i]]);
				printf("\n");
			}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值