POJ 1459 Power Network 多源点多汇点+最大流(EK算法)

点击打开链接

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 20469 Accepted: 10771

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u)  be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

Source

 

 

题的大体意思就是说一个电力网络有n个点,有np个发电站,nc个消耗点,其余的为中转站。m条电缆,中转站既不发电也不耗电。每条电缆都有一个最大容量。

思路就是设置一个超级源点和一个超级汇点将所有的源点和汇点分别放进去,然后直接EK算法。以下就是挫折码。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<queue>
#define INF 999999
using namespace std;
int cap[107][107],flow[107][107];//cap容量,flow流量
int p[107],a[107];//p是父亲编号,a是残量
int n,np,nc,m;
queue<int>q;
int EK(int s,int t)
{
    int sum=0;
    memset(p,0,sizeof(p));
    while(1)
    {
        memset(a,0,sizeof(a));
        q.push(s);
        a[s]=INF;
        while(!q.empty())
        {
            int u=q.front();
            q.pop();
            for(int i=0;i<=n+1;i++)
            {
                if(!a[i]&&cap[u][i]>flow[u][i])
                {
                    p[i]=u;
                    a[i]=a[u]<cap[u][i]-flow[u][i]?a[u]:cap[u][i]-flow[u][i];
                    q.push(i);
                }
            }
        }
        if(!a[t])break;
        for(int i=t;i!=s;i=p[i])
        {
            flow[p[i]][i]+=a[t];
            flow[i][p[i]]-=a[t];
        }
        sum+=a[t];
    }
    return sum;
}
int main()
{
    while(scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
    {
        memset(cap,0,sizeof(cap));
        memset(flow,0,sizeof(flow));
        char ch;
        int a,b,u;
        for(int i=0;i<m;i++)//边的信息
        {
            cin>>ch>>a>>ch>>b>>ch>>u;
            cap[a+1][b+1]+=u;
        }
        for(int i=0;i<np;i++)//发电厂信息
        {
            cin>>ch>>a>>ch>>u;
            cap[0][a+1]=u;
        }
        for(int i=0;i<nc;i++)//耗电用户的信息
        {
            cin>>ch>>a>>ch>>u;
            cap[a+1][n+1]=u;
        }
        int ans=EK(0,n+1);
        printf("%d\n",ans);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值