HDU 2444 The Accomodation of Students 判断是否为二分匹配+求最大匹配数

点击打开链接

 

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1543    Accepted Submission(s): 749


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 


 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 


 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 


 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 


 

Sample Output
  
  
No 3
 


 

Source
 

 

 

题意是有n个学生,有m对认识的,每一对认识的能分到一间房间。首先让你判断能否把这些学生分成两组,要求每组的学生都互不认识。如果能分成两组,求最多需要多少个房间。

首先要判断是不是二部图,用到的方法是染色法。首先取一个点染成黑色,然后将其相邻的点染成白色,如果发现有相邻且同色的点,那么就退出,可知这个图并非二分图。如果是二分图,再求其最大匹配数就行。

#include<stdio.h>
#include<string.h>
using namespace std;
int map[207][207];
int color[207],link[207];
bool vis[207],flag;
int n,m;
void dfs(int i,int col)
{
    for(int j=1;j<=n;j++)
    if(map[i][j])
    {
        if(!color[j])
        {
            color[j]=-col;
            dfs(j,color[j]);
        }
        else if(color[j]==col)//如果下一个点的颜色和这个点颜色相同,说明就不是最大匹配
        {
            flag=false;
            return;
        }
        if(flag==false)
        return ;
    }
}
bool check()
{
    flag=true;
    color[1]=1;//颜色1代表黑色,-1代表白色
    dfs(1,1);
    return flag;
}
bool find(int i)
{
    for(int j=1;j<=n;j++)
    if(map[i][j]&&!vis[j])
    {
        vis[j]=true;
        if(link[j]==0||find(link[j]))
        {
            link[j]=i;
            return true;
        }
    }
    return false;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(map,0,sizeof(map));
        memset(color,0,sizeof(color));
        memset(link,0,sizeof(link));
        int a,b,ans=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            map[a][b]=map[b][a]=1;
        }
        if(!check())//判断是不是二分图
        {
            printf("No\n");
            continue;
        }
        for(int i=1;i<=n;i++)//求最大匹配数
        {
            memset(vis,false,sizeof(vis));
            if(find(i))
            ans++;
        }
        printf("%d\n",ans/2);
    }
    return 0;
}


 

 

 

 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值