HDU 1325&&POJ 1308 Is It A Tree? 并查集判断能否树(能否形成环)

点击打开链接

 

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10528    Accepted Submission(s): 2422


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

 


 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 


 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 


 

Sample Input
  
  
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 


 

Sample Output
  
  
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 


 

Source
 


 

Recommend
Ignatius.L

 

 

题意是让你判断给你的数据能否形成树。树的要求是不能形成环而且除了根节点外其他结点的入度都为1。

此题不是很难用,并查集做,可惜A了一下午。。。

#include<stdio.h>
#include<string.h>
using namespace std;
int pre[100005],vis[100005],u[100005],index[100005];//vis判断是否存在,index代表入度
void init()
{
    memset(vis,0,sizeof(vis));
    memset(index,0,sizeof(index));
    memset(u,-1,sizeof(u));
    for(int i=0;i<100005;i++)
        pre[i]=i;
}

int find(int x)
{
    while(x!=pre[x])
        x=pre[x];
    return x;
}

void unio(int x,int y)
{
    int a,b;
    a=find(x);
    b=find(y);
    if(a==b)return;
    pre[b]=a;
}
int main()
{
    int cas=1,n,m;
    while(scanf("%d%d",&n,&m),n>=0&&m>=0)
    {
        init();
        vis[n]=1;
        vis[m]=1;
        index[m]++;
        u[m]=n;
        unio(n,m);
        while(scanf("%d%d",&n,&m),n||m)
        {
            vis[n]=1;
            vis[m]=1;
            if(u[m]!=n)
            {
                index[m]++;
                u[m]=n;
            }
            unio(n,m);
        }
       int sum=0,sum1=0,f=-1;
       for(int i=0;i<100005;i++)
       {
           if(vis[i]==1&&find(i)!=f)//如果说只有一个根节点
           {
               f=find(i);
               sum1++;
           }
           if(vis[i]==1&&index[i]!=1)//如果除了根节点之外,其他结点的入度都为1
                sum++;
       }
       if(sum==1&&sum1==1)
            printf("Case %d is a tree.\n",cas++);
        else
            printf("Case %d is not a tree.\n",cas++);
    }
    return 0;
}


 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值