PAT A1076 Forward on Weibo

时间限制: 3000 ms    内存限制: 64 MB    代码长度限制: 16 KB

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

 大概题意:

微博是在中国类似Twitter。用户在微博上可能有很多粉丝,并且可能关注很多其他的用户。社会网络是基于粉丝关系的,当某个用户发布一条微博,他的所有粉丝都能看到并转发他的微博,该微博也可以被其他下一级粉丝转发。现给出社会网络,请计算在L层粉丝圈范围内,某人发布微博的粉丝最大可能传播范围。(包括L层)

输入格式:

现给出一行表示总共有N个人,限制转发最大层数是L(其中N<=1000,L<=6)

 

代码初步:

#include <iostream>
#include <algorithm>
#include <queue>
#include <cstring>

using namespace std;
const int maxn=1010;

struct Node{
    int id;
    int layer;
};
vector<Node> Adj[maxn];
bool inq[maxn] = {false};

//to bfs the graph and calculate the amount of user can triger
int BFS(int Su, int L){//start user, layer
    queue<Node> q;
    int numForward = 0;//number of forward
    Node user;//the first user
    user.id=Su; user.layer=0;
    q.push(user);   //push and record
    inq[user.id]=true;
    while(!q.empty()){
        Node topNode = q.front();
        q.pop();
        int u = topNode.id;
        for(int i=0; i<Adj[u].size();i++){
            Node next = Adj[u][i];
            next.layer = topNode.layer+1;
            if(inq[next.id]==false && next.layer<=L){
                q.push(next);   //push and record
                inq[next.id]=true;
                numForward++;
            }
        }
    }
    return numForward;
}

int main()
{
    Node user;
    int n, L, numFollow, idFollow;
    //input section:generate the graph
    scanf("%d %d",&n, &L);
    for(int i=1; i<=n; i++){
        user.id=i;
        scanf("%d", &numFollow);
        for(int j=0; j<numFollow; j++){
            scanf("%d",&idFollow);
            Adj[idFollow].push_back(user);
        }
    }
    //processing section
    int k, userid;
    int numForward[k];
    scanf("%d", &k);
    for(int i=0; i<k; i++){
        scanf("%d", &userid);
        memset(inq, false, sizeof(inq));//initialized inq with false,##need to include cstring
        numForward[i] = BFS(userid, L);
    }
    //output section
    for(int i=0; i<k; i++){
        printf("%d\n",numForward[i]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值