L1-8 估值一亿的AI核心代码 (20 分)

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:
6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don’t know

这题确实恶心啊

#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long LL;
const int N = 1e5 + 10;
string a, b, c;
int judge(int x) {
    if (a[x] >= 'a' && a[x] <= 'z' || a[x] == 'I' ||
        (a[x] >= '0' && a[x] <= '9'))
        return 1;
    return 0;
}
int main() {
    ios::sync_with_stdio(false);
    int t;
    cin >> t;
    t++;
    while (t--) {
        b.clear();
        getline(cin, a);
        if (a.size() < 1) continue;
        cout << a << '\n';
        for (int i = 0; i < a.size();) {
            if (a[i] != ' ') {
                b += a[i];
                i++;
            } else {
                int flag = 1;
                for (int j = i + 1; j < a.size(); j++) {
                    if (a[j] != ' ') {
                        flag = 0;
                        if (i && (a[j] >= 'a' && a[j] <= 'z' ||
                                  (a[j] >= '0' && a[j] <= '9') ||
                                  (a[j] >= 'A' && a[j] <= 'Z')))
                            b += ' ';
                        i = j;
                        break;
                    }
                }
                if (flag) {
                    break;
                }
            }
        }
        a = b;
        b.clear();
        for (int i = 0; i < a.size(); i++) {
            if (a[i] >= 'A' && a[i] <= 'Z' && a[i] != 'I') {
                b += a[i] - 'A' + 'a';
            } else if (a[i] == '?')
                b += '!';
            else
                b += a[i];
        }
        a = b;
        b.clear();
        for (int i = 0; i < a.size();) {
            int f = 0;
            if (a[i] == 'I') {
                f = 1;
                if (i > 0 && judge(i - 1)) f = 0;
                if (i < a.size() - 1 && judge(i + 1)) f = 0;
                if (f) {
                    b += "You";
                    i++;
                }
            }
            if (a[i] == 'm' && i + 1 < a.size() && a[i + 1] == 'e') {
                f = 1;
                if (i > 0 && judge(i - 1)) f = 0;
                if (i < a.size() - 2 && judge(i + 2)) f = 0;
                if (f) {
                    b += "You";
                    i += 2;
                }
            }
            if (f == 0) {
                b += a[i];
                i++;
            }
        }
        a = b;
        b.clear();
        for (int i = 0; i < a.size();) {
            int f = 0;
            if (i + 6 < a.size()) {
                c = a.substr(i, 7);
                if (c == "can you") {
                    f = 1;
                    if (i > 0 && judge(i - 1)) f = 0;
                    if (i + 7 < a.size() && judge(i + 7)) f = 0;
                    if (f) {
                        b += "I can";
                        i += 7;
                    }
                }
            }
            if (i + 8 < a.size()) {
                c = a.substr(i, 9);
                if (c == "could you") {
                    f = 1;
                    if (i > 0 && judge(i - 1)) f = 0;
                    if (i + 9 < a.size() && judge(i + 9)) f = 0;
                    if (f) {
                        b += "I could";
                        i += 9;
                    }
                }
            }
            if (f == 0) {
                b += a[i];
                i++;
            }
        }
        cout << "AI: ";
        for (int i = 0; i < b.size(); i++) {
            if (b[i] == 'Y')
                cout << 'y';
            else
                cout << b[i];
        }
        cout << '\n';
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值