杭电多校第三场 HDU 6319 Problem A. Ascending Rating (模拟单调队列)

Problem A. Ascending Rating

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 3701    Accepted Submission(s): 1225


 

Problem Description

Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i-th contestant's QodeForces rating is ai.
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m, say [l,l+m−1], and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=−1and count=0. Everytime he meets a contestant k with strictly higher rating than maxrating, he will change maxrating to ak and count to count+1.
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating and count. Please write a program to figure out the answer.

Input

The first line of the input contains an integer T(1≤T≤2000), denoting the number of test cases.
In each test case, there are 7 integers n,m,k,p,q,r,MOD(1≤m,k≤n≤10^7,5≤p,q,r,MOD≤10^9) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD.
In the next line, there are k integers a1,a2,...,ak(0≤ai≤109), denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially. The values ai(k<i≤n) are then produced as follows :

ai=(p×ai−1+q×i+r)modMOD
It is guaranteed that ∑n≤7×10^7 and ∑k≤2×10^6.

Output

Since the output file may be very large, let's denote maxratingi and counti as the result of interval [i,i+m−1].
For each test case, you need to print a single line containing two integers A and B, where :

AB==∑i=1n−m+1(maxratingi⊕i)∑i=1n−m+1(counti⊕i)
Note that ``⊕'' denotes binary XOR operation.

Sample Input

1

10 6 10 5 5 5 5

3 2 2 1 5 7 6 8 2 9

Sample Output

46 11

题意:

给定一个序列 a[1..n],对于每个长度为 m 的连续子区间, 求出区间 a 的最大值以及从左往右扫描该区间时 a 的最大值的 变化次数。 1 ≤m≤n≤ 10^7。

单调队列从后往前维护区间,每个区间的count就是当前单调队列的元素个数,maxrating就是队列最大值。这个题STL会卡T。

#include<bits/stdc++.h>
#define maxn 10000010
#define ll long long
#define INF 0x3f3f3f3f3f3f3f3f
using namespace std;
struct node
{
    ll lo;
    ll d;
}a[maxn],b[maxn<<1];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        ll n,m,k,p,q,R,mod;
        scanf("%lld%lld%lld%lld%lld%lld%lld",&n,&m,&k,&p,&q,&R,&mod);
        for(int i=1;i<=k;i++)
        {
            scanf("%lld",&a[i].d);
            a[i].lo=i;
        }
        for(int i=k+1;i<=n;i++)
        {
             a[i].d=((p*a[i-1].d)%mod+(q*i)%mod+R)%mod;
             a[i].lo=i;
        }
        ll l=n-m+1,r=n-m;
        ll maxrating=0;
        for(ll i=l;i<=n;i++)
        {
            if(a[i].d>maxrating)
            {
                b[++r].d=a[i].d;
                b[r].lo=i;
                maxrating=a[i].d;
            }
        }
        ll A,B;
        if(r<l)
            A=l,B=l;
        else
            A=b[r].d^l,B=(r-l+1)^l;

        for(ll i=n-m;i>=1;i--)
        {
            if(r>=l)
            {
                if(b[r].lo==i+m)
                    r--;
            }

            if(r<l)
            {
                b[--l].d=a[i].d;
                b[l].lo=a[i].lo;
            }
            else
            {
                while(b[l].d<=a[i].d&&l<=r)
                    l++;
                b[--l].d=a[i].d;
                b[l].lo=a[i].lo;
            }

            if(r<l)
            {
                A+=i;
                B+=i;
            }
            else
            {
                A+=b[r].d^i;
                B+=(r-l+1)^i;
            }
        }
        printf("%lld %lld\n",A,B);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值