HDU - 2054 A == B ?

Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.
Input
each test case contains two numbers A and B.
Output
for each case, if A is equal to B, you should print “YES”, or print “NO”.
Sample Input
1 2
2 2
3 3
4 3
Sample Output
NO
YES
YES
NO

思路:
表面看上去很水的一道题,其实很坑……
由于没给数的范围,故用字符串储存。小数点后无效的0需要删除

代码:

/*Hint:
char *strchr(const char *string, int c);  
查找字符串string中首次出现的位置, NULL结束符也包含在查找中.  
返回一个指针, 指向字符c在字符串string中首次出现的位置, 如果没有找到, 则返回NULL.*/ 
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
    char a[1000000],b[1000000];
    int i,len1,len2;
    while(scanf("%s%s",a,b)!=EOF)
    {
        len1=strlen(a);
        len2=strlen(b);
        if(strchr(a,'.')!=NULL)
        {
            for(i=len1-1;a[i]=='0';i--)
                a[i]='\0';
            if(a[i]=='.')
               a[i]='\0';
        }
        if(strchr(b,'.')!=NULL)
        {
            for(i=len2-1;b[i]=='0';i--)
                b[i]='\0';
            if(b[i]=='.')
               b[i]='\0';
        }
        if(strcmp(a,b)==0)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值