poj

北京大学暑期课:《ACM/ICPC竞赛训练》面向全球招生

Language:
Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10212 Accepted: 3720

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <set>
#include <map>
#include <vector>

using namespace std;
#define maxn 40

int L, R;
int d[maxn][maxn][maxn];
int digit[maxn];

int dfs(int pos, int num1, int num2, int have, int flag)/// num1 & num2 means before the "pos" the amount of "0" & "1".
{
    if(pos == -1)
        return num1 >= num2;/// num1 represent the number of 0, and num2 means 1
    if(!flag && d[pos][num1][num2]!=-1)
        return d[pos][num1][num2];
    int ans = 0;
    int end = flag ? digit[pos] : 1;
    for(int i=0; i<=end; i++) ///know this value is on "pos" position.
    {
        int t1 = num1, t2 = num2, nhave = have;
        if(have && i==0) t1++;
        if(i==1)
        {
            nhave = 1;
            t2++;
        }
        ans += dfs(pos-1, t1, t2, nhave, flag&&i==end);
    }
    if(!flag)
        d[pos][num1][num2] = ans;
    return ans;
}

int cal(int x)
{
    int pos = 0;
    if(x == -1)
        return 0;
    while(x)
    {
        digit[pos++] = x % 2;
        x /= 2;
    }
    return dfs(pos-1, 0, 0, 0, 1);
}

int main()
{
    memset(d, -1, sizeof(d));
    while(~scanf("%d%d", &L, &R))
    {
        printf("%d\n", cal(R) - cal(L-1));
//        for(int i=0; i<4; i++)
//        cout<<d[i][0][0]<<" ";
//        cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值