《算法笔记》3.1小节——入门模拟->简单模拟 问题 E: Shortest Distance (20)

问题 E: Shortest Distance (20)

时间限制: 1 Sec 内存限制: 32 MB

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7

此题是一个模拟题,博主采用的是子列和的思想实现,由于std的命名空间有重名distance变量,故使用std::这样的方式,跟pat甲级1046重复此题

#include <iostream>
#include <algorithm>

const int N = 100005;
int total_distance[N], distance[N];

int main() {
    int n, m, sum = 0;
    std::cin >> n;
    for (int i = 1; i <= n; ++i) {
        std::cin >> distance[i];
        sum += distance[i];
        total_distance[i+1] += sum;
    }
    std::cin >> m;
    while (m--) {
        int a, b;
        int distance1, distance2;
        std::cin >> a >> b;
        if (a > b)
            std::swap(a, b);
        distance2 = total_distance[b] - total_distance[a];
        distance1 = sum - distance2;
        if (distance1 < distance2)
            std::cout << distance1 << std::endl;
        else
            std::cout << distance2 << std::endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

XdpCs

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值