问题 B: Day of Week
时间限制 : 1.000 sec 内存限制 : 32 MB
题目描述
We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.
输入
There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.
输出
Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.
样例输入
21 December 2012
5 January 2013
样例输出
Friday
Saturday
基姆拉尔森计算公式
本公式用来计算指定的年月日是星期几
算法如下:
基姆拉尔森计算公式
W= (d+2m+3(m+1)/5+y+y/4-y/100+y/400+1)%7 //C++计算公式
在公式中d表示日期中的日数,m表示月份数,y表示年数。
w表示星期,w的取值范围是0~ 6,0代表星期日,1~6星期一到星期六。
注意:在公式中有个与其他公式不同的地方:
把一月和二月看成是上一年的十三月和十四月,例:如果是2004-1-10则换算成:2003-13-10来代入公式计算。
#include <iostream>
#include <unordered_map>
using namespace std;
int a[2][13] = {
{0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31},
{0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}
};
unordered_map<string, int> month{
{"January", 13},
{"February", 14},
{"March", 3},
{"April", 4},
{"May", 5},
{"June", 6},
{"July", 7},
{"August", 8},
{"September", 9},
{"October", 10},
{"November", 11},
{"December", 12}};
string Week[8] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"};
int main() {
string month1;
int year, day;
while (cin >> day >> month1 >> year) {
if (month[month1] == 13 || month[month1] == 14)
year--;
int week = (day + 2 * month[month1] + 3 * (month[month1] + 1) / 5 + year + year / 4 - year / 100 + year / 400 +
1) % 7;
cout << Week[week] << endl;
}
return 0;
}