PAT甲级 1153 Decode Registration Card of PAT (25 分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤104) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>

using namespace std;
struct peoInfo {
    string id;
    string type;
    int grade;
    string site;
    string date;
} peo[10005];
struct querryTwo {
    int value;
    string site;
} querry[1001];

bool cmp1(peoInfo p1, peoInfo p2) {
    if (p1.grade == p2.grade)
        return p1.id < p2.id;
    else
        return p1.grade > p2.grade;
}


bool cmp2(querryTwo q1, querryTwo q2) {
    if (q1.value == q2.value)
        return q1.site < q2.site;
    else
        return q1.value > q2.value;
}

int main() {
    int n, m;
    cin >> n >> m;
    string id;
    int grade;
    for (int i = 0; i < n; ++i) {
        cin >> id >> grade;
        peo[i].id = id;
        peo[i].grade = grade;
        peo[i].site = id.substr(1, 3);
        peo[i].date = id.substr(4, 6);
        peo[i].type = id[0];
    }
    int query_id;
    string query_string;
    for (int i = 1; i <= m; ++i) {
        cin >> query_id >> query_string;
        cout << "Case " << i << ": " << query_id << " " << query_string << endl;
        vector<peoInfo> v;
        if (query_id == 1) {
            for (int j = 0; j < n; ++j) {
                if (peo[j].type == query_string)
                    v.push_back(peo[j]);
            }
            if (v.empty())
                cout << "NA" << endl;
            else
                sort(v.begin(), v.end(), cmp1);
            for (auto &s:v)
                printf("%s %d\n", s.id.c_str(), s.grade);
        } else if (query_id == 2) {
            int sum = 0;
            int num = 0;
            for (int j = 0; j < n; ++j) {
                if (peo[j].site == query_string) {
                    sum += peo[j].grade;
                    num++;
                }
            }
            if (num)
                cout << num << " " << sum << endl;
            else
                cout << "NA" << endl;
        } else if (query_id == 3) {
            unordered_map<string, int> map;
            for (int j = 0; j < n; ++j) {
                if (peo[j].date == query_string)
                    map[peo[j].site]++;
            }
            int k = 0;
            for (auto &it:map) {
                querry[k].site = it.first;
                querry[k++].value = it.second;
            }
            if (!map.empty()) {
                sort(querry, querry + k, cmp2);
                for (int j = 0; j < k; ++j)
                    printf("%s %d\n", querry[j].site.c_str(), querry[j].value);
            } else
                cout << "NA" << endl;
        }
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

XdpCs

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值