S - Picture

Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input. 
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+
|   |
|   |

+---+

题解:水题

代码:

#include<stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>

void print(int m,int n)
{
	int i=0,j=0,k;
	//第一行 
	printf("+");
	for(i = 0;i < m;i++) printf("-");
	printf("+\n");
	//中间 
	for(j = 0;j < n;j++)
	{
		printf("|");
		for(i = 0;i < m;i++)printf(" ");
		printf("|\n");
	}
	//最后一行 
	printf("+");
	for(i = 0;i < m;i++) printf("-");
	printf("+\n");
	printf("\n") ;
}
 
int main()  
{  
    int m,n,i,j,k;
    while(scanf("%d%d",&m,&n) != EOF)
    {
    	print(m,n);
	}
    
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值