U - A == B ?

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
Input
each test case contains two numbers A and B. 
Output
for each case, if A is equal to B, you should print "YES", or print "NO".
Sample Input
1 2
2 2
3 3
4 3
Sample Output


NO
YES
YES

NO

题解:这道题神坑...以下列出几个需要注意的地方:

1.虽然例子中只有整数形式,但是在运行时可能有小数,所以我们得用char型数组来存储,而且长度还不小,10000不够...

2.既然有了小数,在比较大小时,1.0和1.000的大小一致,但其在数组中的存储显然不一致,所以需要你对存储的数组进行处理,将开头和小数点后面多余的0去掉在进行比较

代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
char str1[100000], str2[100000];
void deal(char *str)
{
	int len;
	char *p = str;
	while( *p == '0')//这个while循环是用来删除前导的无用的零
	p++;
	strcpy(str, p);
	if(strchr(str, '.'))//这个函数就是来查找新的字符串里面是否有小数点存在。
	{
	len = strlen(str);
	p = len + str - 1;//使指针指向字符串数组的最后一个字符。
	while( *p == '0')//把后面末尾的零消掉。
	{
		*p = '\0';
		p--;
	}
	if (*p == '.')//将小数点处理
	*p = 0;
	}
	}
	int main( )
{
		while(scanf("%s%s", str1,str2)!= EOF)
		 {
			deal(str1);
			deal(str2);
			if (strcmp(str1, str2) == 0)
				puts("YES\n");
				else
				puts("NO\n");
		}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值