POJ2069 模拟退火算法

Super Star

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6247 Accepted: 1561 Special Judge

Description

During a voyage of the starship Hakodate-maru (see Problem 1406), researchers found strange synchronized movements of stars. Having heard these observations, Dr. Extreme proposed a theory of "super stars". Do not take this term as a description of actors or singers. It is a revolutionary theory in astronomy. 
According to this theory, starts we are observing are not independent objects, but only small portions of larger objects called super stars. A super star is filled with invisible (or transparent) material, and only a number of points inside or on its surface shine. These points are observed as stars by us. 

In order to verify this theory, Dr. Extreme wants to build motion equations of super stars and to compare the solutions of these equations with observed movements of stars. As the first step, he assumes that a super star is sphere-shaped, and has the smallest possible radius such that the sphere contains all given stars in or on it. This assumption makes it possible to estimate the volume of a super star, and thus its mass (the density of the invisible material is known). 

You are asked to help Dr. Extreme by writing a program which, given the locations of a number of stars, finds the smallest sphere containing all of them in or on it. In this computation, you should ignore the sizes of stars. In other words, a star should be regarded as a point. You may assume the universe is a Euclidean space. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 


x1 y1 z1 
x2 y2 z2 
. . . 
xn yn zn 

The first line of a data set contains an integer n, which is the number of points. It satisfies the condition 4 <= n <= 30. 

The location of n points are given by three-dimensional orthogonal coordinates: (xi, yi, zi) (i = 1, ..., n). Three coordinates of a point appear in a line, separated by a space character. Each value is given by a decimal fraction, and is between 0.0 and 100.0 (both ends inclusive). Points are at least 0.01 distant from each other. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the radius of the smallest sphere containing all given points should be printed, each in a separate line. The printed values should have 5 digits after the decimal point. They may not have an error greater than 0.00001.

Sample Input

4
10.00000 10.00000 10.00000
20.00000 10.00000 10.00000
20.00000 20.00000 10.00000
10.00000 20.00000 10.00000
4
10.00000 10.00000 10.00000
10.00000 50.00000 50.00000
50.00000 10.00000 50.00000
50.00000 50.00000 10.00000
0

Sample Output

7.07107
34.64102

模拟退火算法:随机选取一个值t然后进行范围d搜索,如果没有值比当前值更优就缩小d的大小直到d无限接近于0;

这道题变化的是点的坐标任意一个点当作球心然后将球心逐渐靠近距离最远的那个点记录最小半径最后输出

#include<cstring>
#include<cstdio>
#include<iostream>
#include<string>
#include<queue>
#include<vector>
#include<algorithm>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define clr(a,b) memset(a,b,sizeof(a))
#define eps 1e-9
#define inf 1e99
#define MAX_N 105
typedef long long ll;
struct Point
{
    double x,y,z;
    void input()
    {
        scanf("%lf%lf%lf",&x,&y,&z);
    }
} q[MAX_N];
int n;
double dist(Point a,Point b) //两点之间的距离
{
    return sqrt(pow(abs(a.x-b.x),2)+pow(abs(a.y-b.y),2)+pow(abs(a.z-b.z),2));
}
double Search()
{
    double ans=inf,t=100.0;
    Point s;
    int k=0;
    while(t>eps)
    {
        for(int i=0;i<n;i++)
        {
            if(dist(s,q[i])>dist(s,q[k])){k=i;}
        }
        double d=dist(s,q[k]);
        ans=min(d,ans);
        //经典的球覆盖算法
        s.x+=(q[k].x-s.x)/d*t;
        s.y+=(q[k].y-s.y)/d*t;
        s.z+=(q[k].z-s.z)/d*t;
        t*=0.98;
    }
    return ans;
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        double x,y;
        for(int i=0; i<n; i++)
        {
            q[i].input();
        }
        printf("%.5f\n",Search());
    }
    return 0;
}

 

评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值