【Jason's_ACM_解题报告】Even Parity

这是一篇关于如何使用部分枚举策略解决Even Parity问题的博客。问题要求在N×N的网格中,通过最小数量的0到1的转换,使每个单元格的奇偶性变为偶数。文章提供了输入输出示例,并展示了一个通过枚举第一行来减少计算复杂度的解决方案,将时间复杂度从暴力枚举降低到部分枚举。
摘要由CSDN通过智能技术生成

Even Parity

We have a grid of size N × N. Each cell of the grid initially contains a zero(0) or a one(1). The parity of a cell is the number of 1s surrounding that cell. A cell is surrounded by at most 4 cells (top, bottom, left, right).


Suppose we have a grid of size 4 × 4:


For this problem, you have to change some of the 0s to 1s so that the parity of every cell becomes even. We are interested in the minimum number of transformations of 0 to 1 that is needed to achieve the desired requirement.


Input
The first line of input is an integer T (T < 30) that indicates the number of test cases. Each case starts with a positive integer N (1 ≤ N ≤ 15). Each of the next N lines contain N integers (0/1) each. The integers are separated by a single space character.


Output
For each case, output the case number followed by the minimum number of transformations required. If it’s impossible to achieve the desired result, then output ‘-1’ instead.


Sample Input
3
3
0 0 0
0 0 0
0 0 0
3
0 0 0
1 0 0
0 0 0
3
1 1 1
1 1 1
0 0 0


Sample Output
Case 1: 0
Case 2: 3
Case 3: -1


此题采用部分枚举的手段,通过枚举第一行(对于每一个测试数据最坏仅仅需要枚举2^15种情况),将余下n-1行对应的确切结果推导出来,减少无谓的枚举,将时间复杂度从暴力枚举的O(2^(15*15))减低到了部分枚举的O((2^15)*(n^2))。


附代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm> 

using namespace std;

#define INF 100000+5
#define MAXN 15+5

int A[MAXN][MAXN],B[MAXN][MAXN];
int n;

int check(int s){
	memset(B,0,sizeof(B));
	for(int c=0;c<n;c++){
		if(s & (1<<c)) B[0][c]=1;
		else if(A[0][c]==1) return INF;
	}
	for(int r=1;r<n;r++){
		for(int c=0;c<n;c++){
			int sum=0;//计算A[r-1][c]的Parity值 
			if(r>1)sum+=B[r-2][c];
			if(c>0)sum+=B[r-1][c-1];
			if(c<n-1)sum+=B[r-1][c+1];
			B[r][c]=sum%2;
			if(A[r][c]==1&&B[r][c]==0) return INF;
		}
	}
	int num=0;
	for(int r=0;r<n;r++){
		for(int c=0;c<n;c++){
			if(A[r][c]!=B[r][c])num++;
		}
	}
	return num;
}

int main(){
	int total;
	scanf("%d",&total);
	for(int k=1;k<=total;k++){
		scanf("%d",&n);
		for(int r=0;r<n;r++)
			for(int c=0;c<n;c++) scanf("%d",&A[r][c]);
		
		int ans=INF; 
		for(int s=0;s<(1<<n);s++){
			ans=min(ans,check(s));
		}
		if(ans==INF)ans=-1;
		printf("Case %d: %d\n",k,ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值