Assemble
Recently your team noticed that the computer you use to practice for programming contests is not good enough anymore. Therefore, you decide to buy a new computer.
To make the ideal computer for your needs, you decide to buy separate components and assemble the computer yourself. You need to buy exactly one of each type of component.The problem is which components to buy. As you all know, the quality of a computer is equal to the quality of its weakest component. Therefore, you want to maximize the quality of the component with the lowest quality, while not exceeding your budget.
Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase: One line with two integers: 1 ≤ n ≤ 1000, the number of available components and 1 ≤ b ≤ 1000000000, your budget.• n lines in the following format: ``type name price quality'', where type is a string with the type of the component, name is a string with the unique name of the component, price is an integer (0 ≤ price < 1000000) which represents the price of the component and quality is an integer (0 ≤ quality ≤ 1000000000) which represents the quality of the component (higher is better). The strings contain only letters, digits and underscores and have a maximal length of 20 characters.
• It will always possible to construct a computer with your budget.
Output
Per testcase:• One line with one integer: the maximal possible quality.
Sample Input
118 800
processor 3500_MHz 66 5
processor 4200_MHz 103 7
processor 5000_MHz 156 9
processor 6000_MHz 219 12
memory 1_GB 35 3
memory 2_GB 88 6
memory 4_GB 170 12
mainbord all_onboard 52 10
harddisk 250_GB 54 10
harddisk 500_FB 99 12
casing midi 36 10
monitor 17_inch 157 5
monitor 19_inch 175 7
monitor 20_inch 210 9
monitor 22_inch 293 12
mouse cordless_optical 18 12
mouse microsoft 30 9
keyboard office 4 10
Sample Output
9
此题很容易想到使用“二分法”求解,对品质进行二分,每次取大于品质的最小的component,求所有components的总价值,若不超过budget,则可行,继续二分,直到逼近答案。
软肋仍旧在于对于字符串的处理。
本来早上八点就写出来了,可老是WA,查了一上午,敲了两边,最后发现错误在于对初始值的处理和c类型字符串的输入出现了问题(c风格字符串名前面不能加&符号,对字符串的各种运用的总结归纳迫在眉睫了)。
对了,还有位移运算符的优先级问题,(L+R)>>1+1和((L+R)>>1)+1的结果是截然不同的,这个问题,昨天做题就发现了,只不过今天没有重视起来。
看来还要开一篇文章对运算符优先级进行总结归纳。
附代码如下:
#include<algorithm>
#include<cstdio>
#include<vector>
#include<string>
#include<map>
using namespace std;
#define MAXN (1000+5)
struct COMPONENT{
int price,quality;
};
int n,budget,cnt;
map<string,int> id;
vector<COMPONENT> component[MAXN];
int ID(string s){
if(!id.count(s))id[s]=cnt++;
return id[s];
}
bool check(int level){
int sum=0;
for(int i=0;i<cnt;i++){
int cheapest=budget+1;
int num=component[i].size();
for(int j=0;j<num;j++){
if(component[i][j].quality>=level)
cheapest=min(cheapest,component[i][j].price);
}
if(cheapest==budget+1)return false;
sum+=cheapest;
if(sum>budget)return false;
}
return true;
}
int main(){
//freopen("in.txt","r",stdin);
int total;
scanf("%d",&total);
while(total--){
scanf("%d%d",&n,&budget);
id.clear();
for(int i=0;i<cnt;i++)component[i].clear();
cnt=0;
int L=0,R=0;
for(int i=0;i<n;i++){
char type[20],name[20];
int p,q;
scanf("%s%s%d%d",type,name,&p,&q);
//printf("%s %s\n",type,name);
component[ID(type)].push_back((COMPONENT){p,q});
R=max(R,q);
}
while(L<R){
int /*MID=L+(R-L+1)/2;*/MID=((L+R)>>1)+1;
//printf("%d %d %d",L,MID,R);
if(check(MID))L=MID;
else R=MID-1;
}
printf("%d\n",L);
}
//fclose(stdin);
return 0;
}