【Jason's_ACM_解题报告】Broken Keyboard (a.k.a. Beiju Text)

Broken Keyboard (a.k.a. Beiju Text)

You're typing a long text with a broken keyboard. Well it's not so badly broken. The only problem with the keyboard is that sometimes the "home" key or the "end" key gets automatically pressed (internally).


You're not aware of this issue, since you're focusing on the text and did not even turn on the monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor).


In Chinese, we can call it Beiju. Your task is to find the Beiju text.


Input
There are several test cases. Each test case is a single line containing at least one and at most 100,000 letters, underscores and two special characters '[' and ']'. '[' means the "Home" key is pressed internally, and ']' means the "End" key is pressed internally. The input is terminated by end-of-file (EOF). The size of input file does not exceed 5MB.


Output
For each case, print the Beiju text on the screen.


Sample Input
This_is_a_[Beiju]_text
[[]][][]Happy_Birthday_to_Tsinghua_University


Sample Output
BeijuThis_is_a__text
Happy_Birthday_to_Tsinghua_University

这一章的题对我来说受益匪浅,好好地打好基础比什么都重要,用数组模拟指针。

我们这样想,一方面,模拟坏损键盘的读入,字符串s1;另一方面,模拟相应正确键盘的读入,字符串s2。

对于s2,我们要对s1进行扫描,首先我们要模拟s2中光标cur的移动,当在s1中遇到 ' [ ' 符号时,光标应立刻指向s2第一个字符的前面,并且我们设置一个last来记录当前s2的最后一个字符的位置,以方便当我们在s1中遇到 ' ] ' 时可以立刻将光标指向最后一个字符的后面。其次,当我们在s1中遇到一个字母或者下划线的时候我们将它插入到s2的光标后面。

在具体实现的时候,由于数据规模的制约,我们需要使用链表进行解决,将链表看作s2。在链表中,我们只需要记录下每一个字符在原来s1中的位置即可。最终可以依照链表输出结果。


附代码如下:
#include<cstdio> 
#include<cstring>

using namespace std;

#define MAXN (100000+5)

char str[MAXN];
int next[MAXN];
int cur,last;

int main(){
	while(scanf("%s",str+1)!=EOF){
		int n=strlen(str+1);
		int cur=0,last=0;
		next[0]=0;
		for(int i=1;i<=n;i++){
			if(str[i]=='[')cur=0;
			else if(str[i]==']')cur=last;
			else{
				next[i]=next[cur];
				next[cur]=i;
				if(cur==last)last=i;
				cur=i;
			}
		}
		for(int i=next[0];i!=0;i=next[i]){
			printf("%c",str[i]);
		}
		printf("\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值