【Jason's_ACM_解题报告】Dropping Balls

Dropping Balls 

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball's moving direction a flag is set up in every non-terminal node with two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag's current value at this node is false, then the ball will first switch this flag's value, i.e., from the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag's value, i.e., from the true to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.

For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag's values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag's values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag's values at node 1, node 2, and node 5 before it stops at position 10.


Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.


Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of I will not exceed the total number of leaf nodes for the given FBT.


Please write a program to determine the stop position P for each test case.


For each test cases the range of two parameters D and I is as below: 
\begin{displaymath}2 \le D \le 20, \mbox{ and } 1 \le I \le 524288.\end{displaymath}




Input 
Contains l+2 lines.


Line 1   I the number of test cases 
Line 2  $D_1 \ I_1$
test case #1, two decimal numbers that are separatedby one blank 
...     
Line k+1         $D_k \ I_k$
test case #k
Line l+1           $D_l \ I_l$
test case #l 
Line l+2 -1   a constant -1 representing the end of the input file


Output 
Contains l lines.


Line 1   the stop position P for the test case #1 
...   
Line k the stop position P for the test case #k 
...   
Line l the stop position P for the test case #l


Sample Input 
5
4 2
3 4
10 1
2 2
8 128
-1


Sample Output 

12
7
512
3
255

完全二叉树(FBT,full binary tree)的学习,首先题目可以模拟,但是由于测试数据可能有10000组。所以普通模拟是会超时的。

此处我们可以直接模拟当前下落小球的轨迹,因为,对于节点x来说,若当前小球编号P为奇,则向左下落,否则向右。而对于节点x的左子节点来说,当前小球为第P/2+1个经过此点的,对于节点x的右子节点来说,则为第P/2个。以此类推,所以我们使用递推的手法解决此题。

(理解:假若当前下落小球编号为第P个,节点编号为X,若P为偶数,说明应向想右下落,而在小球P经过节点X*2+1之前已经有P/2个小球经过了节点X*2,以及有P/2-1个小球经过了节点X*2+1,所以经过X*2+1节点的小球为第P/2个。同理可以想到左边的情况。)


附代码如下:

第一种(AC代码):

#include<cstdio>

using namespace std;

int main(){
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		int D,I;
		scanf("%d%d",&D,&I);
		int ans=1;
		for(int j=1;j<D;j++){
			if(I%2){
				ans=ans*2;
				I=I/2+1;
			}else{
				ans=ans*2+1;
				I=I/2;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}
第二种(模拟代码):
#include<cstdio> 
#include<cstring>

using namespace std;

#define MAXN (524300)
#define CLR(x,y) (memset(x,y,sizeof(x)))

bool flag[MAXN];

int main(){
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		int D,I;
		scanf("%d%d",&D,&I);
		CLR(flag,false);
		int next;
		for(int j=0;j<I;j++){
			next=1;
			for(int k=1;k<D;k++){
				bool f=flag[next];
				flag[next]=!flag[next];
				if(f)next=2*next+1;else next*=2;
			}
		}
		printf("%d\n",next);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值