【Jason's_ACM_解题报告】Trees on the level

Trees on the level 

Background
Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.


In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree
picture28
is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

Input
The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

Output
For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

Sample Input
(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output
5 4 8 11 13 4 7 2 1
not complete

这道题主要是技能题,学到了如何建立二叉树以及操作。

Liu使用了指针的操作方式,其实还可以使用数组的方式。

另外还有一些零碎的知识点,如:
1.strchr(s,ch)返回字符串s中ch第一次出现的位置;

2.sscanf(&s,"%d",&x)将s中的数字字符按照整数的形式读入x中;

3.new x()申请一个类型名为x的指针变量;

4.delete x;析构,即使放该类型的指针。


附代码如下:
#include<cstdio> 
#include<cstring> 
#include<vector>
#include<queue>

using namespace std;

#define MAXN (300)

struct NODE{
	bool isvalued;
	int value;
	NODE *left,*right;
	NODE():isvalued(false),left(NULL),right(NULL){}
};

NODE* root;
bool error;

NODE* newnode(){
	return new NODE();
}

void addnode(int x,char* p){
	int n=strlen(p);
	NODE* tmp=root;
	for(int i=0;i<n;i++){
		if(p[i]=='L'){
			if(tmp->left==NULL)tmp->left=newnode();
			tmp=tmp->left;
		}else if(p[i]=='R'){
			if(tmp->right==NULL)tmp->right=newnode();
			tmp=tmp->right;
		}
	}
	if(tmp->isvalued)error=true;
	tmp->isvalued=true;
	tmp->value=x;
}

void remove_tree(NODE* N){
	if(N==NULL)return ;
	remove_tree(N->left);
	remove_tree(N->right);
	delete N;
}

bool input(){
	char s[MAXN];
	error=false;
	remove_tree(root);
	root=newnode();
	for(;;){
		if(scanf("%s",s)!=1)return false;
		if(!strcmp(s,"()"))break;
		int x;
		sscanf(&s[1],"%d",&x);
		addnode(x,strchr(s,',')+1);
	}
	return true;
}

bool bfs(vector<int>& ans){
	queue<NODE*> q;
	ans.clear();
	q.push(root);
	while(!q.empty()){
		NODE* tmp=q.front();q.pop();
		if(!tmp->isvalued)return false;//判断树中是否有未被复制的点。 
		ans.push_back(tmp->value);
		if(tmp->left!=NULL)q.push(tmp->left);
		if(tmp->right!=NULL)q.push(tmp->right);
	}
	return true;
}

int main(){
	while(input()){
		vector<int> ans;
		if(error){printf("not complete\n");continue;}
		if(bfs(ans)){
			printf("%d",ans[0]);
			for(int i=1;i<ans.size();i++)printf(" %d",ans[i]);printf("\n");
		}else printf("not complete\n");
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值