【Jason's_ACM_解题报告】Krypton Factor

Krypton Factor 

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy''. Other sequences will be called ``hard''.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

·BB
·ABCDACABCAB
·ABCDABCD

Some examples of hard sequences are:

·D
·DC
·ABDAB
·CBABCBA

Input and Output
In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range  1<=L<=26 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:


AB 
ABA 
ABAC 
ABACA 
ABACAB 
ABACABA
As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

ABAC ABA
7
Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

Sample Input
30 3
0 0

Sample Output
ABAC ABCA CBAB CABA CABC ACBA CABA
28

这道题写了两遍,自我感觉自己对回溯算法的掌握有些熟练了,第一遍写的时候直接在递归函数里写上了输出和判断过程,但是感觉思路有些混乱,但是第二遍写的时候将输出与判断过程都独立出来写进了独立的函数里,书写的速度也快了许多。

附代码如下:

第二次的代码:

#include<cstdio>

using namespace std;

#define MAXN (100)

int N,L,total;
int ans[MAXN];

bool check(int cur){
	for(int len=1;len*2<=cur+1;len++){
		bool flag=true;
		for(int i=0;i<len;i++){
			if(ans[cur-i]!=ans[cur-len-i])flag=false;
		}
		if(flag)return false;
	}
	return true;
}

void output(int len){
	for(int i=0;i<len;i++){
		if(i%64==0&&i)printf("\n");
		else if(i%4==0&&i)printf(" ");
		printf("%c",ans[i]+'A');
	}
	printf("\n%d\n",len);
}

bool dfs(int cur){
	if(total==N){
		output(cur);
		return false;
	}else{
		for(int i=0;i<L;i++){
			ans[cur]=i;
			if(check(cur)){
				total++;
				if(!dfs(cur+1))return false;
			}
		}
	}
	return true;
}

int main(){
	while(scanf("%d%d",&N,&L)==2&&N&&L){
		total=0;
		dfs(0);
	}
	return 0;
}

第一次的代码:

#include<cstdio> 
#include<cstring>

using namespace std;

#define MAXLEN (100)

int N,L,total;
char ans[MAXLEN];

bool check(int n){
	for(int i=1;i<=(n+1)/2;i++){
		bool equal=true;
		for(int j=0;j<i;j++){
			if(ans[n-j]!=ans[n-i-j])equal=false;
		}
		if(equal)return false;
	}
	return true;
}

bool dfs(int current){
	if(total==N){
		for(int i=0;i<current;i++){
			printf("%c",ans[i]);
			if((i+1)%4==0&&(i+1)%64!=0&&i+1!=current)printf(" ");
			if((i+1)%64==0||i==current-1){
				printf("\n");
			}
		}printf("%d\n",current);
		return false;
	}else{
		for(int i=0;i<L;i++){
			ans[current]=i+'A';
			if(check(current)){
				total++;
				if(!dfs(current+1))return false;
			}
		}
	}
	return true; 
}

int main(){
	while(scanf("%d%d",&N,&L)==2&&N&&L){
		total=0;
		dfs(0);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值