【Jason's_ACM_解题报告】Building for UN

Building for UN

The United Nations has decided to build a new headquarters in Saint Petersburg, Russia. It will have a form of a rectangular parallelepiped and will consist of several rectangular floors, one on top of another. Each floor is a rectangular grid of the same dimensions, each cell of this grid is an office.


Two offices are considered adjacent if they are located on the same floor and share a common wall, or if one's floor is the other's ceiling.


The St. Petersburg building will host n national missions. Each country gets several offices that form a connected set.


Moreover, modern political situation shows that countries might want to form secret coalitions. For that to be possible, each pair of countries must have at least one pair of adjacent offices, so that they can raise the wall or the ceiling they share to perform secret pair-wise negotiations just in case they need to.


You are hired to design an appropriate building for the UN.


Input 
Input consists of several datasets. Each of them has a single integer number n (1<=n<=50) -- the number of countries that are hosted in the building.


Output 
On the first line of the output for each dataset write three integer numbers h , w , and l -- height, width and length of the building respectively.


h descriptions of floors should follow. Each floor description consists of l lines with w characters on each line. Separate descriptions of adjacent floors with an empty line.


Use capital and small Latin letters to denote offices of different countries. There should be at most 1 000 000 offices in the building. Each office should be occupied by a country. There should be exactly n different countries in the building. In this problem the required building design always exists. Print a blank line between test cases.


Sample Input 
4


Sample Output 
2 2 2 
AB 
CC 


zz 
zz



此题是一道不限制解答方案的题目,评测系统会对你提交的程序进行特判,所以会有多种解题方法。

其中比较经典也值得关注的解法是:仅设置两层楼,每层楼为N×N的网格,第一层的每一行是同一个国家,第二层的每一列是同一个国家,这样即可满足题目要求。



附代码如下:
#include<cstdio>

using namespace std;

int n;

int main(){
	bool isfirstline=true;
	while(scanf("%d",&n)==1){
		if(!isfirstline)printf("\n");
		isfirstline=false;
		printf("2 %d %d\n",n,n);
		for(int i=0;i<n;i++){
			char ch=i/26==1?i%26+'a':i+'A';
			for(int j=0;j<n;j++)printf("%c",ch);printf("\n");
		}
		printf("\n");
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				char ch=j/26==1?j%26+'a':j+'A';
				printf("%c",ch);
			}
			printf("\n");
		}
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值