【Jason's_ACM_解题报告】Lighting System Design

Lighting System Design

You are given the task to design a lighting system for a huge conference hall. After doing a lot of calculation & sketching, you have figured out the requirements for an energy-efficient design that can properly illuminate the entire hall. According to your design, you need lamps of n different power ratings. For some strange current regulation method, all the lamps need to be fed with the same amount of current. So, each category of lamp has a corresponding voltage rating. Now, you know the number of lamps & cost of every single unit of lamp for each category. But the problem is, you are to buy equivalent voltage sources for all the lamp categories. You can buy a single voltage source for each category (Each source is capable of supplying to infinite number of lamps of its voltage rating.) & complete the design. But the accounts section of your company soon figures out that they might be able to reduce the total system cost by eliminating some of the voltage sources & replacing the lamps of that category with higher rating lamps. Certainly you can never replace a lamp by a lower rating lamp as some portion of the hall might not be illuminated then. You are more concerned about money-saving than energy-saving. Find the minimum possible cost to design the system.
 
Input 
Each case in the input begins with n (1<=n<=1000), denoting the number of categories. Each of the following n lines describes a category. A category is described by 4 integers - V (1<=V<=132000), the voltage rating, K (1<=K<=1000), the cost of a voltage source of this rating, C (1<=C<=10), the cost of a lamp of this rating & L (1<=L<=100), the number of lamps required in this category. The input terminates with a test case where n = 0. This case should not be processed.
 
Output 
For each test case, print the minimum possible cost to design the system.
 
Sample Input
3
100 500 10 20
120 600 8 16
220 400 7 18
0


Sample Output
778

 

有题意可知,电流恒定,则电压越大功率越大,所以将低电压的电灯换为更高电压的电灯可能会获得更优的解答。但是需要注意的是,一种电灯要么全部都换作另一种更高典雅的,要么就不换。例如,如果100伏特的电灯有2个,当把2个电灯全部换作200伏特的时候需要的电源仅有200伏特的,当不作调整时仅需100伏特的,如果仅仅只将一个换作200伏特,另一个仍然是100伏特的,那么此时需要两种电源,显然不划算。

所以题目应当将每组数据按照伏特为关键字升序排序,并求灯泡数量的前缀和,另外有状态转移方程dp[i]=min{dp[j]+(sum[i]-sum[j])*c[i]+k[i]}(j<i)。

 
 
附代码如下:
#include<cstdio> 

#include<algorithm>

using namespace std;

#define MAXN (1000+5)
#define OO (0x7fffffff)

struct LAMPS{
	int V,K,C,L;
	bool operator < (const LAMPS& rhs) const {return V<rhs.V;}
};

int n,sum[MAXN],dp[MAXN];
LAMPS a[MAXN];

int main(){
	while(scanf("%d",&n)==1&&n){
		sum[0]=0;
		for(int i=1;i<=n;i++)scanf("%d%d%d%d",&a[i].V,&a[i].K,&a[i].C,&a[i].L);
		sort(a+1,a+n+1);
		for(int i=1;i<=n;i++)sum[i]=sum[i-1]+a[i].L;
		dp[0]=0;
		for(int i=1;i<=n;i++){
			dp[i]=OO;
			for(int j=0;j<i;j++){
				dp[i]=min(dp[i],dp[j]+(sum[i]-sum[j])*a[i].C+a[i].K);
			}
		}
		
		printf("%d\n",dp[n]);
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值