【Jason's_ACM_解题报告】Brackets sequence

Brackets sequence

Let us define a regular brackets sequence in the following way:



Empty sequence is a regular sequence.
If S is a regular sequence, then (S) and [S] are both regular sequences.
If A and B are regular sequences, then AB is a regular sequence.
For example, all of the following sequences of characters are regular brackets sequences:


(), [], (()), ([]), ()[], ()[()]


And all of the following character sequences are not:


(, [, ), )(, ([)], ([(]


Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1a2...an is called a subsequence of the string b1b2...bm, if there exist such indices 1 ≤ i1 < i2 < ... < in ≤ m, that aj=bij for all 1 ≤ j ≤ n.


Input 
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.


Output 
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.


Sample Input 

1


([(]


Sample Output 
()[()]

此题仍然是类似于最优矩阵链乘、Cutting Sticks之类的题目。他们的共性都是长区间的最优值依赖于短区间的最优值,所以在递推的过程中应当按照区间长度递推从而保证最优解。

当然此题的特色在于,使用递归的方法输出最优解的实例。

状态dp[i][j]表示字符串第i位到第j位最少需要添加dp[i][j]个Brackets。

状态决策如下:

1.若str[i]与str[j]可以配对,则dp[i][j]=min(dp[i][j],dp[i+1][j-1]);

2.若j-i>0不管是否可以配对,均将str[i]~str[j]分割为两部分进行求解,即dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j])(i<=k<j)。

边界为dp[i][i]=1;最终结果为dp[1][n]。


附代码如下:
#include<cstdio> 
#include<cstring>

#include<algorithm>

using namespace std;

#define MAXN (100+5)

int n;
char str[MAXN];
int dp[MAXN][MAXN];

void input(){
	char ch=getchar();
	n=0;
	while(ch!='\n'){
		str[++n]=ch;
		ch=getchar();
	}
	getchar();
}

bool match(int x,int y){
	return ((str[x]=='('&&str[y]==')')||(str[x]=='['&&str[y]==']'));
}

void DP(){
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=n;i++)dp[i][i]=1;
	for(int len=1;len<=n;len++){
		for(int i=1;i+len<=n;i++){
			int j=i+len;
			dp[i][j]=n;
			if(match(i,j))dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
			for(int k=i;k<j;k++){
				dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]);
			}
		}
	}
}

void print(int i,int j){
	if(i>j)return;
	if(i==j){
		if(str[i]=='('||str[i]==')')printf("()");else printf("[]");
		return;
	}
	int level=dp[i][j];
	if(match(i,j)&&dp[i][j]==dp[i+1][j-1]){
		printf("%c",str[i]);print(i+1,j-1);printf("%c",str[j]);
		return;
	}
	for(int k=i;k<j;k++){
		if(level==dp[i][k]+dp[k+1][j]){
			print(i,k);print(k+1,j);
			return;
		}
	}
}

int main(){
	int T;
	scanf("%d\n",&T);
	while(T--){
		input();
		DP();
		print(1,n);printf("\n");
		if(T)printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值