Description
Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.
Input
The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.
Output
For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.
Sample Input
1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107
Sample Output
143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127
思路
类似于n阶皇后的一个回溯算法,和n阶皇后不同的是这里要有三个判断,同行的数不能相同,同列的数不能相同,9方格的数不能相同。一开始我用循环判断,但效率太低,这里提供一种用数组标记的判断。
代码
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int a[10][10],num;
bool h[10][10],l[10][10],hl[4][4][10];
void DFS(int i)
{
if(num==81)
return;
for(;i<=9;i++)
for(int j=1;j<=9;j++)
{
if(a[i][j])
continue;
for(int k=1;k<=9;k++)
{
if(h[i][k]&&l[j][k]&&hl[(i+2)/3][(j+2)/3][k])
{
num++;
a[i][j]=k;
h[i][k]=l[j][k]=hl[(i+2)/3][(j+2)/3][k]=false;
DFS(i);
if(num==81)
return;
num--;
a[i][j]=0;
h[i][k]=l[j][k]=hl[(i+2)/3][(j+2)/3][k]=true;
}
if(k==9&&a[i][j]==0)
return;
}
}
}
int main()
{
int t;
cin>>t;
while(t--)
{
num=0;
memset(h,true,sizeof(h));
memset(l,true,sizeof(l));
memset(hl,true,sizeof(hl));
for(int i=1;i<=9;i++)
for(int j=1;j<=9;j++)
{
scanf("%1d",&a[i][j]);
if(a[i][j])
{
num++;
h[i][a[i][j]]=false;
l[j][a[i][j]]=false;
hl[(i+2)/3][(j+2)/3][a[i][j]]=false;
}
}
DFS(1);
for(int i=1;i<=9;i++)
{
for(int j=1;j<=9;j++)
printf("%d",a[i][j]);
printf("\n");
}
}
return 0;
}