POJ3295--Tautology(模拟)

26 篇文章 0 订阅

Description

WFF ‘N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:
p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.

w xKwxAwxNwCwxEwx
1 111011
1 001000
0 100110
0 000111

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.
You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

题意

有K , C , A, E, N 五种运算符, p,q,r,s,t五种运算数,运算得到重言式输出tautology, 不是重言式输出not,
重言式是指永真式,即无论输入什么,结果都为1.

思路

运算数p , q , r, s, t都只有0,1两种输入,枚举所有情况即可。
map映射
只有32种情况,int型变量的二进制数就可以代表所以情况(状态压缩)
K 相当于 p && q
A 相当于 p || q
N 相当于 !p
C 相当于 p→q
E 相当于 p↔q

代码

#include <cstdio>
#include <iostream>
#include <stack>
#include <map>
#include <cstring>

using namespace std;
char str[110];
stack<int > s;
map<char, int> mp;
int wwf;
int len, n;
int tmp1 , tmp2;
void getbit(int i)
{
    mp['s'] = (i >> 0) & 1;
    mp['p'] = (i >> 1) & 1;
    mp['q'] = (i >> 2) & 1;
    mp['r'] = (i >> 3) & 1;
    mp['t'] = (i >> 4) & 1;
}
bool gao()
{
    for(int i = 0; i < 32; i ++)
    {
        getbit(i);
        for(int j = len-1; j >= 0; j --)
        {
            switch(str[j])
            {
                case 'K':
                tmp1 = s.top(); s.pop();
                tmp2 = s.top(); s.pop();
                s.push(tmp1 && tmp2); //与
                break;
                case 'A':
                tmp1 = s.top(); s.pop();
                tmp2 = s.top(); s.pop();
                s.push(tmp1 || tmp2);//或
                break;
                case 'C':
                tmp1 = s.top(); s.pop();
                tmp2 = s.top(); s.pop();
                s.push(!tmp1 || tmp2);//→
                break;
                case 'N':
                tmp1 = s.top(); s.pop();
                s.push(!tmp1);//非
                break;
                case 'E':
                tmp1 = s.top(); s.pop();
                tmp2 = s.top(); s.pop();
                s.push((!tmp1 || tmp2)&&(tmp1 || !tmp2));//↔
                break;
                default :
                s.push(mp[str[j]]);
            }
        }
        if(s.top() == 0)
            return false;
    }
    return true;
}
int main()
{
    while(cin >> str && str[0] != '0')
    {
        len = strlen(str);
        if(gao())
            cout << "tautology" << endl;
        else
            cout << "not" << endl;
    }
}

位运算大法好

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值