POJ3295 栈

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not
此题思路就是,从右边开始读入,如果是数就推入栈,如果是运算符就根据运算符取数出来运算
#include <iostream>
#include <cstring>
#include <string>
#include <stack>
using namespace std;
int P[]={0,1};
int Q[]={0,1};
int R[]={0,1};
int S[]={0,1};
int T[]={0,1};
int main()
{
	char Z[110];
	while(cin>>Z&&Z[0]!='0')
	{
		int len=strlen(Z);
		bool flag=true;
		for(int i1=0;i1<=1;i1++)
		{
			for(int i2=0;i2<=1;i2++)
			{
				for(int i3=0;i3<=1;i3++)
				{
					for(int i4=0;i4<=1;i4++)
					{
						for(int i5=0;i5<=1;i5++)
						{
							stack <char> q;
							int m,n;
							for(int i=len-1;i>=0;i--)
							{
								if(Z[i]>='Z')
								{
									if(Z[i]=='p')
									{
										q.push(P[i1]+'0');
									}
									if(Z[i]=='q')
									{
										q.push(Q[i2]+'0');
									}
									if(Z[i]=='r')
									{
										q.push(R[i3]+'0');
									}
									if(Z[i]=='s')
									{
										q.push(S[i4]+'0');
									}
									if(Z[i]=='t')
									{
										q.push(T[i5]+'0');
									}
								}
								if(Z[i]=='K')
								{
									m=q.top()-'0';
									q.pop();
									n=q.top()-'0';
									q.pop();
									q.push((m&&n)+'0');
								}
								if(Z[i]=='A')
								{
									m=q.top()-'0';
									q.pop();
									n=q.top()-'0';
									q.pop();
									q.push((m||n)+'0');
								}	
								if(Z[i]=='N')
								{
									m=q.top()-'0';
									q.pop();
									q.push((!m)+'0');
								}
								if(Z[i]=='C')
								{
									m=q.top()-'0';
									q.pop();
									n=q.top()-'0';
									q.pop();
									q.push(((!m)||n)+'0');
								}
								if(Z[i]=='E')
								{
									m=q.top()-'0';
									q.pop();
									n=q.top()-'0';
									q.pop();
									q.push(m==n?'1':'0');
								}
							}
							if(!(q.top()-'0'))
							{
								flag=false;
								goto L;
							}
						}
					}
				}
			}
		}
		L:
		if(flag)
		{
			cout<<"tautology"<<endl;
		}
		else cout<<"not"<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值