Problem Description
对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。
input
输入一个算术表达式,以‘#’字符作为结束标志。
Output
输出该表达式转换所得到的后缀式。
Example Input
a*b+(c-d/e)*f#
Example Output
ab*cde/-f*+
思路
栈的基本运算。 两个栈,一个存放运算符,另一个存放后缀表达式
当字符为运算数的时候,直接进如postexp栈
当字符为‘(’时入栈optr
当字符为“-,+”时,弹出前面所有的“+,-,*,/”运算符直到栈optr为空或者遇到‘(’
当字符为“/,* ”,弹出前面所有的“*,/”运算符直到栈optr为空或者遇到‘(’
当字符为‘)’时,弹出前面所有的“+,-,*,/”运算符直到栈optr为空或者遇到‘(’弹出‘(’。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <stack>
#include <cstring>
using namespace std;
stack<char>optr; //运算符栈
stack<char>postexp; //后缀表达式栈
char a[100];
int n;
void gao()
{
for(int i = 0; i < n-1; i ++)
{
switch(a[i])
{
case '+':
case '-':
while( !optr.empty() )
{
if( optr.top() == '(')
break;
postexp.push( optr.top() );
optr.pop();
}
optr.push(a[i]);
break;
case '*':
case '/':
while( !optr.empty() )
{
if( optr.top() == '(')
{
break;
}
else if( optr.top() == '+' || optr.top() == '-')
break;
postexp.push( optr.top() );
optr.pop();
}
optr.push(a[i]);
break;
case '(':
optr.push(a[i]);
break;
case ')':
while( !optr.empty() )
{
if( optr.top() == '(')
{
optr.pop();
break;
}
postexp.push( optr.top() );
optr.pop();
}
break;
default :
postexp.push(a[i]);
}
}
while( !optr.empty() )
{
postexp.push( optr.top() );
optr.pop();
}
int i = 0;
while( !postexp.empty() )
{
a[i++] = postexp.top();
postexp.pop();
}
for(int j = i-1; j >= 0; j --)
cout << a[j];
cout << endl;
}
int main()
{
cin >> a;
n = strlen(a);
gao();
}