HDU 1058 Humble Numbers

Humble Numbers

  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

 Total Submission(s): 11507    Accepted Submission(s): 5012
 

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
 

Recommend
JGShining

这是一个经典的动态规划 题目  一开始做这类题目 在读题目的时候都没感受到这个算法很是神奇    一开始的时候只想到穷举暴力的方法   从1到2000000000,判断是否对2、3、5、7整除存入到数组,以为这样就AC了。。。最后提交时WA。。查一下才知道是DP 百度博客一看。。才发现题目都读错了。。。

题目意思是:一个数从1开始,里面的数都是2、3、5、7的倍数。。。但是每次取最小的并同时增加对应的下标,后移,即h[i]=min(2*h[m],3*h[k],5*h[j],7*h[l])

但是最后那个。。。输出  我倒一直没想明白。。。不知道那个是怎么想到的。。。只根据那个样例输出。。。。真心跪了

代码:

#include<stdio.h>
int h[5843],n,j,m,k,l;
int min(int a,int b,int c,int d)
{
   int mint=a;
   if(mint>b) mint=b;
   if(mint>c) mint=c;
   if(mint>d) mint=d;
   if(mint==a) m++;
   if(mint==b) k++;
   if(mint==c) j++;
   if(mint==d) l++;
   return mint;
}
int main()
{
  j=m=k=l=1;
  h[1]=1;
  int i;
  for(i=2;i<5843;i++)
  {
	  h[i]=min(2*h[m],3*h[k],5*h[j],7*h[l]);
  }
  while(scanf("%d",&n)!=EOF)
  {
	if(n==0)
		  break;
    if(n%10==1&&n%100!=11)
		printf("The %dst humble number is %d.\n",n,h[n]);
	else if(n%10==2&&n%100!=12)
		printf("The %dnd humble number is %d.\n",n,h[n]);
	else if(n%10==3&&n%100!=13)
		printf("The %drd humble number is %d.\n",n,h[n]);
	else printf("The %dth humble number is %d.\n",n,h[n]);
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值