HDU1010 Tempter of the Bone

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54374    Accepted Submission(s): 14637


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 

Author
ZHANG, Zheng
 

Source
 

Recommend
JGShining
代码1:62MS
#include<iostream>
#include<string>
#include<cmath>
using namespace std;
char  map[10][10];
int sx,sy,ex,ey;
int flag;
int a[4][2]={-1,0,0,-1,1,0,0,1};
int n,m,t;
void dfs(int x,int y,int t)
{
    int nx,ny;
    int i;
  if(flag!=1)
  {

    if(t<fabs(ex-x)+fabs(ey-y)||(t-fabs(ex-x)+fabs(ey-y))%2);
    else if(t==0)
    {
       if(x==ex&&y==ey)
       {
           flag=1;

       }

    }
    else
    {
        for(i=0;i<4;i++)
        {
            nx=x+a[i][0];ny=y+a[i][1];
            if(nx>=0&&nx<n&&ny>=0&&ny<m&&(map[nx][ny]=='.'||map[nx][ny]=='D'))
            {
                map[nx][ny]='D';
                dfs(nx,ny,t-1);
                map[nx][ny]='.';
            }

        }
    }
  }

}
int main()
{
    int i,j;
    string str;
    while(cin>>n>>m>>t)
    {
        for(i=0;i<n;i++)
        {
            cin>>str;
            for(j=0;j<m;j++)
              {
                 map[i][j]=str[j];
                  if(map[i][j]=='S')
                    sx=i,sy=j;
                  if(map[i][j]=='D')
                    ex=i,ey=j;
             }
       }
           flag=0;
           dfs(sx,sy,t);
           if(flag)
           cout<<"YES"<<endl;
           else
           cout<<"NO"<<endl;
    }
    return 0;
}
代码2:140MS
#include <iostream>
using namespace std;

int row,column,time;
int op[4][2] = {-1,0,1,0,0,-1,0,1};
char grap[10][10];
int start_x,start_y,end_x,end_y;  //起点,终点
int count;
int sign;

//当前点的X,Y坐标,t为起点到当前点的时间
void dfs(int x,int y,int t)
{
    int X,Y;
    int i;
    if(sign)  //如果已经找到解了,都要返回
    {
        return ;
    }
    if(end_x == x && end_y == y && t == time)  //找到目标
    {
        sign = 1;
        return ;
    }
    if( (time - t) % 2 != (x+y+end_x+end_y) % 2 )  //奇偶减枝法
    {
        return ;
    }
    if(abs(x-end_x) + abs(y-end_y) > time - t)   //当前点到终点的最短时间若比剩余的时间还长的话
    {
        return;
    }
    for(i=0;i<4;i++)
    {
        X = x + op[i][0];
        Y = y + op[i][1];
        if(X <= 0 || X > row || Y <= 0 || Y > column) //判断是否越界
        {
            continue;
        }
        if(grap[X][Y] != 'X')
        {
            grap[X][Y] = 'X';  //将走过的.变为X
            dfs(X,Y,t+1); //往下搜索,t+1
            grap[X][Y] = '.';  //回溯恢复X为.
        }
    }
}

int main()
{
    int i,j;
    while(cin>>row>>column>>time,row+column+time)
    {
        count = 0;
        sign = 0;
        for(i=1;i<=row;i++)
        {
            for(j=1;j<=column;j++)
            {
                cin>>grap[i][j];
                //找到起点
                if(grap[i][j] == 'S')
                {
                    start_x = i;
                    start_y = j;
                    grap[i][j] = 'X'; //将起点标记为'X',不能重复走
                }
                //找到终点
                if(grap[i][j] == 'D')
                {
                    end_x = i;
                    end_y = j;
                }
                if(grap[i][j] == '.')
                {
                    count++;
                }
            }
        }
        //总共可以走的步数如果比给定时间还少
        if(count + 1 < time)
        {
            cout<<"NO"<<endl;
            continue;
        }
        //从起点开始搜索
        dfs(start_x,start_y,0);
        if(sign)
        {
            cout<<"YES"<<endl;
        }
        else
            cout<<"NO"<<endl;

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值