[kuangbin专题] KMP HDU 1711 Number Sequence

题目链接

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

 

题目大意:给两个串,找子串最早在主串中匹配的位置,没匹配到的话输出-1

KMP直接匹配就ok了

 

AC代码

#include <stdio.h>
int next[10100],a1[1000100],a2[10100];
void getnext(int m){
	int i=0,j=-1;
	next[0]=-1;
	while(i<m){
		if(j==-1||a2[i]==a2[j]){
			j++;i++;
			next[i]=j;
		}
		else j=next[j];
	}
}
void kmp(int n,int m){
	int i=0,j=0;
	int flag=1;
	while(i<n){
		if(j==-1||a1[i]==a2[j]){
			i++;
			j++;
		}
		else j=next[j];
		if(j==m){
			printf("%d\n",i-j+1);
			flag=0;
			return;
		}
	}
	if(flag) printf("-1\n");
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int i,j,n,m;
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++){
			scanf("%d",&a1[i]);
		}
		for(i=0;i<m;i++){
			scanf("%d",&a2[i]);
		}
		getnext(m);
		kmp(n,m);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值