HDU-2141 Can you find it? 二分查找(详细思路)

题目链接

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO

【题目大意】:给三个数组a,b,c,每个数组取一个数,判断是否能加出来下面的数

【思路】:二分查找,因为给了三个数组,如果把三个数组能组合出来的所有情况都遍历出来存到一个数组里面,这个数组需要开500*500*500,显然开不了这么大的。于是就把前两个数组的所有能组合出来的数都存到一个数组里,再把这个数组sort一下。因为a+b+c=x,所以a+b=x-c。所有a+b已经有了,遍历x-c[i],用二分查找寻找有没有a+b=x-c。就酱~

二分查找就是那个find函数

AC代码

#include <stdio.h>
#include <algorithm>
using namespace std;
int y,ab[300000];
int find(int l,int r){
	int mid=(l+r)/2;
	if(ab[mid]==y) return 1;
	if(l==r) return -1;
	if(ab[mid]<y) find(mid+1,r);
	else find(1,mid);
}
int main(){
	int i,j,l,n,m,a[500],b[500],c[500],cnt=1;
	while(~scanf("%d%d%d",&l,&n,&m)){
		for(i=0;i<l;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		for(i=0;i<m;i++)
			scanf("%d",&c[i]);
		int len=0;
		for(i=0;i<l;i++)
			for(j=0;j<n;j++)
				ab[len++]=a[i]+b[j];
		sort(ab,ab+len);
		int s,x;
		scanf("%d",&s);
		printf("Case %d:\n",cnt++);
		while(s--){
			scanf("%d",&x);
			int flag=0;
			for(i=0;i<m&&flag!=1;i++){
				y=x-c[i];
				flag=find(1,len);
			}
			if(flag==1) printf("YES\n");
			else printf("NO\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的纺织品企业财务管理系统,源码+数据库+毕业论文+视频演示 在如今社会上,关于信息上面的处理,没有任何一个企业或者个人会忽视,如何让信息急速传递,并且归档储存查询,采用之前的纸张记录模式已经不符合当前使用要求了。所以,对纺织品企业财务信息管理的提升,也为了对纺织品企业财务信息进行更好的维护,纺织品企业财务管理系统的出现就变得水到渠成不可缺少。通过对纺织品企业财务管理系统的开发,不仅仅可以学以致用,让学到的知识变成成果出现,也强化了知识记忆,扩大了知识储备,是提升自我的一种很好的方法。通过具体的开发,对整个软件开发的过程熟练掌握,不论是前期的设计,还是后续的编码测试,都有了很深刻的认知。 纺织品企业财务管理系统通过MySQL数据库与Spring Boot框架进行开发,纺织品企业财务管理系统能够实现对财务人员,员工,收费信息,支出信息,薪资信息,留言信息,报销信息等信息的管理。 通过纺织品企业财务管理系统对相关信息的处理,让信息处理变的更加的系统,更加的规范,这是一个必然的结果。已经处理好的信息,不管是用来查找,还是分析,在效率上都会成倍的提高,让计算机变得更加符合生产需要,变成人们不可缺少的一种信息处理工具,实现了绿色办公,节省社会资源,为环境保护也做了力所能及的贡献。 关键字:纺织品企业财务管理系统,薪资信息,报销信息;SpringBoot
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值