HDOJ 1004 java代码实现--引用相等要用 equals()

题目链接: 点击打开链接
题目大意:求输入的n个字符串,数量最多的一共字符串。
本人第一次做,由于判断字符串是否相等,使用==判断,导致一直不对,后面查阅书本得知,引用需使用equals()方法判断,方AC

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 119180    Accepted Submission(s): 46715


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
   
   
5 green red blue red red 3 pink orange pink 0
 

Sample Output
   
   
red pink
具体代码实现:
import java.util.*;
class Main{
	public static void main(String args[]){
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int n=sc.nextInt();
			String str[]=new String[n];
			int a[]=new int[n];		//该数组用于存放从该位置之后,一共有多少个字符串与该位置的字符串相同
			for(int i=0;i<n;i++){
				a[i]=0;
			}
			if(n==0){
				break;
			}
			for(int i=0;i<n;i++){
				str[i]=sc.next();
			}
			for(int i=0;i<n;i++){
				for(int j=i+1;j<n;j++){;
					if(str[i].equals(str[j])){		//因为这里的str[]是引用/所以不能直接用==判断
						a[i]++;
					}
				}
			}
			int t=0;
			for(int i=0;i<n;i++){
				if(a[i]>a[t]){
					t=i;								//找到最大的那个就是最多
				}
			}
			System.out.println(str[t]);
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值