HDOJ 1005 找规律 周期性

题目链接:点击打开链接

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 170847    Accepted Submission(s): 42150


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
本题应该找到规律才能 AC 否则不是超内存就是超时
看了很大大牛的代码与想法:我总结出该题的规律———这个题目答案是具有周期性的,这个大家都知道,就是关于循环周期的计算:
先假设周期为T 则f(3)=f(3+T),f(4)=f(4+T ),
又因为f(T+5)=(f(T+4)*a+f(T+3)*b)%7=(f(4)*a+f(3)*b)%7=f(5);
所以只需要当f(3)=f(T+3)&&f(4)==f(T+4)时可以得到周期为T
代码实现如下:
package acm;

import java.util.Scanner;

public class P1005 {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int a=sc.nextInt();
			int b=sc.nextInt();
			int n=sc.nextInt();
			int f[]=new int[1000];
			if(a==0&&b==0&&n==0){
				break;
			}
			f[1]=1;
			f[2]=1;
			int x=f[3]=(a+b)%7;
			int y=f[4]=(a*x+b)%7;
			int t=1;
			for(int i=5;i<999;i++){
				f[i]=(a*f[i-1]+b*f[i-2])%7;
				if(f[i-1]==x&&f[i]==y){
					t=i-4	//周期是i-4
					break;
				}
			}
			System.out.println(f[(n-3)%t+3]);
		}
	}
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值