HDOJ 1312 Red and Black (简单dfs)

此题为一个简单dfs模板题。

题目大意为:“@”表示人所在位置,“.”表示黑色瓷砖(表示可以移动到此位置),"#"表示红色瓷砖(表示不能移动到此位置)

注意:此题输入为先是行数再是列数

题目链接:点击打开链接

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20216    Accepted Submission(s): 12308


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13

具体代码实现如下:

import java.util.Scanner;

public class Main{
	
	public static char a[][];			//字符数组
	public static boolean color[][];	//标记数组
	public static final int b[][]={{0,1},{0,-1},{-1,0},{1,0}};
	//上下左右,四个方向
	public static int count,w,h;
	
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			w=sc.nextInt();
			h=sc.nextInt();
			if(w==0&&h==0){
				break;
			}
			a=new char[h][w];
			color=new boolean[h][w];
			int x=-1,y=-1;
			for(int i=0;i<h;i++){
				String str=sc.next();
				sc.nextLine();
				a[i]=str.toCharArray();
				for(int j=0;j<w;j++){
					color[i][j]=true;
					if(a[i][j]=='@'){
						x=i;
						y=j;		//记录人所在位置
					}
				}
			}
			color[x][y]=false;
			count=1;	
			dfs(x,y);	//从人所在位置开始搜索
			System.out.println(count);
		}
	}
	public static void dfs(int x,int y){
		for(int i=0;i<4;i++){
			int nx=x+b[i][0];
			int ny=y+b[i][1];
			if(nx>=0&&nx<h&&ny>=0&&ny<w){
				if(color[nx][ny]&&(a[nx][ny]=='.'||a[nx][ny]=='@')){
					color[nx][ny]=false;
					//System.out.println("***");
					count++;
					dfs(nx,ny);
					//color[nx][ny]=true;
					//这个不需要回溯使标记为true
				}
			}
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值