HDOJ 1312 Red and Black(BFS)

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
//
//  main.cpp
//  red and black
//
//  Created by 张嘉韬 on 16/3/25.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
using namespace std;
int dx[]={-1,1,0,0};
int dy[]={0,0,-1,1};
int m,n,map[30][30],book[30][30],sx,sy,counter;
struct node
{
    int x;
    int y;
}nodes[500];
int safe(int x,int y)
{
    int flag=1;
    if(x<=0||x>n||y<=0||y>m||map[x][y]==0||book[x][y]==1) flag=0;
    return flag;
}
void bfs(int x,int y)
{
    int head,tail;
    head=tail=1;
    nodes[tail].x=x;
    nodes[tail].y=y;
    book[x][y]=1;
    tail++;
    while(head<tail)
    {
        int tempx,tempy;
        for(int i=0;i<4;i++)
        {
            tempx=nodes[head].x+dx[i];
            tempy=nodes[head].y+dy[i];
            if(safe(tempx,tempy)==1)
            {
                nodes[tail].x=tempx;
                nodes[tail].y=tempy;
                book[tempx][tempy]=1;
                tail++;
                counter++;
            }
        }
        head++;
    }
    
}
int main(int argc, const char * argv[]) {
    //freopen("/Users/zhangjiatao/Desktop/input.txt","r",stdin);
    while(scanf("%d%d",&m,&n)==2)
    {
        if(m==0&&n==0) return 0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                char temp;
                cin>>temp;
                if(temp=='.') map[i][j]=1;
                else if(temp=='#') map[i][j]=0;
                else sx=i,sy=j;
                book[i][j]=0; //0 is avil ,1 is used
            }
        }
        counter=0;
        bfs(sx,sy);
        cout<<counter+1<<endl;
    }
    return 0;
}

总结
这次写的其实挺顺利的,主要是按照了书上有良好的代码风格,以后也要注意,自己思考写下固然很重要但不可否认的是自己写的一套总是出现一些细节上的小问题,这些小问题反而不好找出来,所以,在自己思考吃透了算法的思想可以照着优秀的代码去构建自己的代码风格
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值